DCCORE: VPC Basic Configuration

Configuration

NXOS1


hostname NXOS1

feature lacp
feature vpc



vlan 1,10
vlan 10
  name VLAN-10

spanning-tree vlan 1-3967 priority 0
vrf context management
vpc domain 1
  role priority 1
  peer-keepalive destination 10.0.0.2 source 10.0.0.1


interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface port-channel10
  switchport mode trunk
  switchport trunk allowed vlan 10
  vpc 10

interface Ethernet1/1
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/2
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/3
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10 mode active

interface Ethernet1/4
  switchport mode trunk
  switchport trunk allowed vlan 10


interface mgmt0
  vrf member management
  ip address 10.0.0.1/30
line console
  exec-timeout 0
line vty
boot nxos bootflash:/nxos.9.2.4.bin

NXOS2

hostname NXOS2

feature lacp
feature vpc

vlan 1,10
vlan 10
  name VLAN-10

spanning-tree vlan 1-3967 priority 4096
vrf context management
vpc domain 1
  role priority 100
  peer-keepalive destination 10.0.0.1 source 10.0.0.2


interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface port-channel10
  switchport mode trunk
  switchport trunk allowed vlan 10
  vpc 10

interface Ethernet1/1
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/2
  switchport mode trunk
  channel-group 1 mode active

interface Ethernet1/3
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10 mode active

interface Ethernet1/4
  switchport mode trunk
  switchport trunk allowed vlan 10

interface mgmt0
  vrf member management
  ip address 10.0.0.2/30
line console
  exec-timeout 0
line vty
boot nxos bootflash:/nxos.9.2.4.bin

NXOS3

NXOS3 is connected to upstream via a VPC.

hostname NXOS3

feature lacp

vlan 1,10
vlan 10
  name VLAN-10

vrf context management

interface port-channel10
  switchport mode trunk
  switchport trunk allowed vlan 10

interface Ethernet1/1
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10 mode active

interface Ethernet1/2
  switchport mode trunk
  switchport trunk allowed vlan 10
  channel-group 10 mode active

interface Ethernet1/3
  switchport access vlan 10
  spanning-tree port type edge

interface mgmt0
  vrf member management
line console
  exec-timeout 0
line vty
boot nxos bootflash:/nxos.9.2.4.bin

NXOS4

NXOS4 is connected to upstream via two individual trunk links.

hostname NXOS4

feature lacp

vlan 1,10
vlan 10
  name VLAN-10

vrf context management

interface Ethernet1/1
  switchport mode trunk
  switchport trunk allowed vlan 10

interface Ethernet1/2
  switchport mode trunk
  switchport trunk allowed vlan 10

interface Ethernet1/3
  switchport access vlan 10
  spanning-tree port type edge

interface mgmt0
  vrf member management
line console
  exec-timeout 0
line vty
boot nxos bootflash:/nxos.9.2.4.bin

HOST1

hostname HOST1
!
no ip domain lookup
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ip ospf 1 area 0
!
interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip ospf 1 area 0
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1
 router-id 10.0.0.1
 passive-interface default
 no passive-interface GigabitEthernet0/0
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous

HOST2

!
hostname HOST2
!
no ip domain lookup
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
 ip ospf 1 area 0
!
interface GigabitEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 ip ospf 1 area 0
 duplex auto
 speed auto
 media-type rj45
!
router ospf 1
 router-id 10.0.0.2
 passive-interface default
 no passive-interface GigabitEthernet0/0
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous

Verification

NXOS1

NXOS1# sh vpc
Legend:
		(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 1
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : primary
Number of vPCs configured         : 1
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled
Delay-restore status              : Timer is off.(timeout = 30s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled
Virtual-peerlink mode             : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id    Port   Status Active vlans
--    ----   ------ -------------------------------------------------
1     Po1    up     1,10


vPC status
----------------------------------------------------------------------------
Id    Port          Status Consistency Reason                Active vlans
--    ------------  ------ ----------- ------                ---------------
10    Po10          up     success     success               10




Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.

NXOS1#

NXOS2

NXOS2# sh vpc
Legend:
		(*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 1
Peer status                       : peer adjacency formed ok
vPC keep-alive status             : peer is alive
Configuration consistency status  : success
Per-vlan consistency status       : success
Type-2 consistency status         : success
vPC role                          : secondary
Number of vPCs configured         : 1
Peer Gateway                      : Disabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled
Delay-restore status              : Timer is off.(timeout = 30s)
Delay-restore SVI status          : Timer is off.(timeout = 10s)
Operational Layer3 Peer-router    : Disabled
Virtual-peerlink mode             : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id    Port   Status Active vlans
--    ----   ------ -------------------------------------------------
1     Po1    up     1,10


vPC status
----------------------------------------------------------------------------
Id    Port          Status Consistency Reason                Active vlans
--    ------------  ------ ----------- ------                ---------------
10    Po10          up     success     success               10




Please check "show vpc consistency-parameters vpc <vpc-num>" for the
consistency reason of down vpc and for type-2 consistency reasons for
any vpc.

NXOS2#

NXOS3

NXOS3# sh vlan id 10

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
10   VLAN-10                          active    Po10, Eth1/1, Eth1/2, Eth1/3

VLAN Type         Vlan-mode
---- -----        ----------
10   enet         CE

Remote SPAN VLAN
----------------
Disabled

Primary  Secondary  Type             Ports
-------  ---------  ---------------  -------------------------------------------



NXOS3#

NXOS4

NXOS4# sh vlan id 10

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
10   VLAN-10                          active    Eth1/1, Eth1/2, Eth1/3

VLAN Type         Vlan-mode
---- -----        ----------
10   enet         CE

Remote SPAN VLAN
----------------
Disabled

Primary  Secondary  Type             Ports
-------  ---------  ---------------  -------------------------------------------


HOST1

HOST1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.0.0.2          1   FULL/BDR        00:00:30    192.168.1.2     GigabitEthernet0/0
HOST1#
HOST1#ping 10.0.0.2 source 10.0.0.1 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 10.0.0.2, timeout is 2 seconds:
Packet sent with a source address of 10.0.0.1
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 21/29/37 ms
HOST1#

HOST2

HOST2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
10.0.0.1          1   FULL/DR         00:00:31    192.168.1.1     GigabitEthernet0/0
HOST2#
HOST2#ping 10.0.0.1 source 10.0.0.2 repeat 100
Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
Packet sent with a source address of 10.0.0.2
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (100/100), round-trip min/avg/max = 22/29/39 ms
HOST2#

Spanning Tree without vPC peer switch configuration

NXOS1

NXOS1# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     5000.0001.0007
             This bridge is the root
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    10     (priority 0 sys-id-ext 10)
             Address     5000.0001.0007
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Desg FWD 3         128.4096 (vPC peer-link) Network P2p
Po10             Desg FWD 1         128.4105 (vPC) P2p
Eth1/4           Desg FWD 4         128.4    P2p

NXOS1#

NXOS2

NXOS2# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     5000.0001.0007
             Cost        3
             Port        4096 (port-channel1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    4106   (priority 4096 sys-id-ext 10)
             Address     5000.0002.0007
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po1              Root FWD 3         128.4096 (vPC peer-link) Network P2p
Po10             Desg FWD 1         128.4105 (vPC) P2p
Eth1/4           Desg FWD 4         128.4    P2p

NXOS2#

NXOS3

NXOS3# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     5000.0001.0007
             Cost        3
             Port        4105 (port-channel10)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     5000.0003.0007
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Po10             Root FWD 3         128.4105 P2p
Eth1/3           Desg FWD 4         128.3    Edge P2p

NXOS3#

NXOS4

NXOS4# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    10
             Address     5000.0001.0007
             Cost        4
             Port        1 (Ethernet1/1)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     5000.0004.0007
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Eth1/1           Root FWD 4         128.1    P2p
Eth1/2           Altn BLK 4         128.2    P2p
Eth1/3           Desg FWD 4         128.3    Edge P2p

NXOS4#

Spanning Tree reconvergence without vPC peer switch

NXOS4

NXOS4# debug spanning-tree event
NXOS4# 2024 Sep  3 14:15:35.944017 stp: sps_check_send(1017): issuing next req
2024 Sep  3 14:15:35.944173 stp: stp_mcs_set_slave_mcec_vlans_multi_port_state(956): Ignore - Not a vPC Master
2024 Sep  3 14:15:35.944199 stp: sps_issue_next_req(938): state BLK ports- num_ports:1 is_issu_in_progress:0, stp_peer_in_upgrade:0,ret_val:0x40dd002d
2024 Sep  3 14:15:35.944381 stp: vb_vlan_shim_set_vlans_multi_port_state(3081): vlan :0xa flc_vlan: 0xa
2024 Sep  3 14:15:35.947887 stp: stp_mcs_set_slave_mcec_vlans_multi_port_state(956): Ignore - Not a vPC Master
2024 Sep  3 14:15:35.947920 stp: sps_issue_next_req(938): state FWD ports- num_ports:1 is_issu_in_progress:0, stp_peer_in_upgrade:0,ret_val:0x40dd002d
2024 Sep  3 14:15:35.947969 stp: vb_vlan_shim_set_vlans_multi_port_state(3081): vlan :0xa flc_vlan: 0xa
2024 Sep  3 14:15:50.944035 stp: sps_check_send(1017): issuing next req
2024 Sep  3 14:15:50.944104 stp: stp_mcs_set_slave_mcec_vlans_multi_port_state(956): Ignore - Not a vPC Master
2024 Sep  3 14:15:50.944146 stp: sps_issue_next_req(938): state LRN ports- num_ports:1 is_issu_in_progress:0, stp_peer_in_upgrade:0,ret_val:0x40dd002d
2024 Sep  3 14:15:50.944686 stp: vb_vlan_shim_set_vlans_multi_port_state(3081): vlan :0xa flc_vlan: 0xa
2024 Sep  3 14:16:05.945086 stp: sps_check_send(1017): issuing next req
2024 Sep  3 14:16:05.945150 stp: stp_mcs_set_slave_mcec_vlans_multi_port_state(956): Ignore - Not a vPC Master
2024 Sep  3 14:16:05.945177 stp: sps_issue_next_req(938): state FWD ports- num_ports:1 is_issu_in_progress:0, stp_peer_in_upgrade:0,ret_val:0x40dd002d
2024 Sep  3 14:16:05.945263 stp: vb_vlan_shim_set_vlans_multi_port_state(3081): vlan :0xa flc_vlan: 0xa
NXOS4# sh spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    4106
             Address     5000.0002.0007
             Cost        4
             Port        2 (Ethernet1/2)
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     5000.0004.0007
             Hello Time  2  sec  Max Age 20 sec  Forward Delay 15 sec

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Eth1/1           Desg FWD 4         128.1    P2p
Eth1/2           Root FWD 4         128.2    P2p
Eth1/3           Desg FWD 4         128.3    Edge P2p

NXOS4#