HOST1 is the multicast Source with IP address 192.168.1.1
HOST2 and HOST3 joins SSM group 232.0.0.1
Device Configuration
R1
hostname R1
!
ip multicast-routing distributed
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.4.1 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.1.254 255.255.255.0
ip pim sparse-mode
ip igmp version 3
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 1.1.1.1
passive-interface default
no passive-interface GigabitEthernet1
1
ip pim ssm default
R2
hostname R2
!
ip multicast-routing distributed
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.2.4.2 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.2.254 255.255.255.0
ip pim sparse-mode
ip igmp version 3
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 2.2.2.2
passive-interface default
no passive-interface GigabitEthernet1
!
ip pim ssm default
R3
hostname R3
!
ip multicast-routing distributed
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.3.4.3 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.3.254 255.255.255.0
ip pim sparse-mode
ip igmp version 3
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 3.3.3.3
passive-interface default
no passive-interface GigabitEthernet1
!
ip pim ssm default
R4
hostname R4
!
ip multicast-routing distributed
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.2.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet3
ip address 10.3.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 4.4.4.4
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet2
no passive-interface GigabitEthernet3
!
ip pim ssm default
HOST1
hostname HOST1
!
ip multicast-routing
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip igmp version 3
HOST2
hostname HOST2
!
ip multicast-routing
!
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
ip igmp join-group 232.0.0.1 source 192.168.1.1
ip igmp version 3
HOST3
hostname HOST2
!
ip multicast-routing
!
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
ip igmp join-group 232.0.0.1 source 192.168.1.1
ip igmp version 3
Verification
HOST1
HOST1#ping 232.0.0.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 232.0.0.1, timeout is 2 seconds:
Reply to request 0 from 192.168.2.1, 3 ms
Reply to request 0 from 192.168.3.1, 3 ms
Reply to request 1 from 192.168.2.1, 2 ms
Reply to request 1 from 192.168.3.1, 2 ms
Reply to request 2 from 192.168.2.1, 2 ms
Reply to request 2 from 192.168.3.1, 2 ms
Reply to request 3 from 192.168.2.1, 2 ms
Reply to request 3 from 192.168.3.1, 2 ms
Reply to request 4 from 192.168.2.1, 2 ms
Reply to request 4 from 192.168.3.1, 2 ms
HOST1#
HOST2
HOST2#show ip igmp membership
Flags: A - aggregate, T - tracked
L - Local, S - static, V - virtual, R - Reported through v3
I - v3lite, U - Urd, M - SSM (S,G) channel
1,2,3 - The version of IGMP, the group is in
Channel/Group-Flags:
/ - Filtering entry (Exclude mode (S,G), Include mode (G))
Reporter:
<mac-or-ip-address> - last reporter if group is not explicitly tracked
<n>/<m> - <n> reporter in include mode, <m> reporter in exclude
Channel/Group Reporter Uptime Exp. Flags Interface
*,232.0.0.1 192.168.2.1 00:38:09 stop 3LA Gi0/0
HOST2#show ip igmp interface gi0/0
GigabitEthernet0/0 is up, line protocol is up
Internet address is 192.168.2.1/24
IGMP is enabled on interface
Current IGMP host version is 3
Current IGMP router version is 3
IGMP query interval is 60 seconds
IGMP configured query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP configured querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query count is 2
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 1 joins, 0 leaves
Multicast routing is disabled on interface
Multicast TTL threshold is 0
Multicast groups joined by this system (number of users):
232.0.0.1(1)
HOST2#
HOST3
HOST3#show ip igmp membership
Flags: A - aggregate, T - tracked
L - Local, S - static, V - virtual, R - Reported through v3
I - v3lite, U - Urd, M - SSM (S,G) channel
1,2,3 - The version of IGMP, the group is in
Channel/Group-Flags:
/ - Filtering entry (Exclude mode (S,G), Include mode (G))
Reporter:
<mac-or-ip-address> - last reporter if group is not explicitly tracked
<n>/<m> - <n> reporter in include mode, <m> reporter in exclude
Channel/Group Reporter Uptime Exp. Flags Interface
*,232.0.0.1 192.168.3.1 00:39:19 stop 3LA Gi0/0
HOST3#
HOST3#
HOST3#show ip igmp interface gi0/0
GigabitEthernet0/0 is up, line protocol is up
Internet address is 192.168.3.1/24
IGMP is enabled on interface
Current IGMP host version is 3
Current IGMP router version is 3
IGMP query interval is 60 seconds
IGMP configured query interval is 60 seconds
IGMP querier timeout is 120 seconds
IGMP configured querier timeout is 120 seconds
IGMP max query response time is 10 seconds
Last member query count is 2
Last member query response interval is 1000 ms
Inbound IGMP access group is not set
IGMP activity: 1 joins, 0 leaves
Multicast routing is disabled on interface
Multicast TTL threshold is 0
Multicast groups joined by this system (number of users):
232.0.0.1(1)
HOST3#
R1
R1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.1.1, 232.0.0.1), 00:33:55/00:03:01, flags: sT
Incoming interface: GigabitEthernet2, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1, Forward/Sparse, 00:33:56/00:03:01
(*, 224.0.1.40), 00:43:38/00:02:26, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:43:36/00:02:26
R1#
R2
R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.1.1, 232.0.0.1), 00:34:22/00:02:35, flags: sTI
Incoming interface: GigabitEthernet1, RPF nbr 10.2.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:34:22/00:02:35
(*, 224.0.1.40), 00:43:39/00:02:27, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:43:37/00:02:27
R2#
R3
R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.1.1, 232.0.0.1), 00:29:32/00:02:24, flags: sTI
Incoming interface: GigabitEthernet1, RPF nbr 10.3.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:29:32/00:02:24
(*, 224.0.1.40), 00:43:13/00:02:50, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:43:11/00:02:50
R3#
R4
R4#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.1.1, 232.0.0.1), 00:35:27/00:03:22, flags: sT
Incoming interface: GigabitEthernet1, RPF nbr 10.1.4.1
Outgoing interface list:
GigabitEthernet3, Forward/Sparse, 00:29:57/00:03:06
GigabitEthernet2, Forward/Sparse, 00:35:27/00:03:22
(*, 224.0.1.40), 00:42:58/00:02:04, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 00:42:56/00:02:04
R4#
hostname R1
!
ip multicast-routing distributed
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.4.1 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.1.254 255.255.255.0
ip pim sparse-mode
ip igmp version 3
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 1.1.1.1
passive-interface default
no passive-interface GigabitEthernet1
!
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0 priority 255
!
ip pim ssm default
!
R2
hostname R2
!
ip multicast-routing distributed
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.2.4.2 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.2.254 255.255.255.0
ip pim sparse-mode
ip igmp version 3
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 2.2.2.2
passive-interface default
no passive-interface GigabitEthernet1
!
ip pim ssm default
R3
hostname R3
!
ip multicast-routing distributed
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.3.4.3 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.3.254 255.255.255.0
ip pim sparse-mode
ip igmp version 3
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 3.3.3.3
passive-interface default
no passive-interface GigabitEthernet1
!
ip pim ssm default
R4
hostname R4
!
ip multicast-routing distributed
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.2.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet3
ip address 10.3.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 4.4.4.4
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet2
no passive-interface GigabitEthernet3
!
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0 priority 128
!
ip pim ssm default
!
HOST1
hostname HOST1
!
ip multicast-routing
!
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
HOST2
hostname HOST2
!
ip multicast-routing
!
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
ip igmp join-group 232.0.0.1 source 192.168.1.1
ip igmp join-group 225.1.1.1
ip igmp version 3
HOST3
hostname HOST2
!
ip multicast-routing
!
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
ip igmp join-group 232.0.0.1 source 192.168.1.1
ip igmp join-group 225.1.1.1
ip igmp version 3
Verification
HOST1
HOST1#ping 225.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:
Reply to request 0 from 192.168.2.1, 34 ms
Reply to request 0 from 192.168.3.1, 35 ms
Reply to request 1 from 192.168.2.1, 13 ms
Reply to request 1 from 192.168.3.1, 51 ms
Reply to request 1 from 192.168.2.1, 51 ms
Reply to request 1 from 192.168.3.1, 13 ms
Reply to request 2 from 192.168.2.1, 2 ms
Reply to request 2 from 192.168.3.1, 2 ms
Reply to request 3 from 192.168.2.1, 2 ms
Reply to request 3 from 192.168.3.1, 2 ms
Reply to request 4 from 192.168.2.1, 2 ms
Reply to request 4 from 192.168.3.1, 2 ms
HOST1#
HOST2
HOST2#show ip igmp membership
Flags: A - aggregate, T - tracked
L - Local, S - static, V - virtual, R - Reported through v3
I - v3lite, U - Urd, M - SSM (S,G) channel
1,2,3 - The version of IGMP, the group is in
Channel/Group-Flags:
/ - Filtering entry (Exclude mode (S,G), Include mode (G))
Reporter:
<mac-or-ip-address> - last reporter if group is not explicitly tracked
<n>/<m> - <n> reporter in include mode, <m> reporter in exclude
Channel/Group Reporter Uptime Exp. Flags Interface
*,232.0.0.1 192.168.2.1 01:02:23 stop 3LA Gi0/0
*,225.1.1.1 192.168.2.1 00:12:39 never 3LA Gi0/0
HOST2#
HOST3
HOST3#show ip igmp membership
Flags: A - aggregate, T - tracked
L - Local, S - static, V - virtual, R - Reported through v3
I - v3lite, U - Urd, M - SSM (S,G) channel
1,2,3 - The version of IGMP, the group is in
Channel/Group-Flags:
/ - Filtering entry (Exclude mode (S,G), Include mode (G))
Reporter:
<mac-or-ip-address> - last reporter if group is not explicitly tracked
<n>/<m> - <n> reporter in include mode, <m> reporter in exclude
Channel/Group Reporter Uptime Exp. Flags Interface
*,232.0.0.1 192.168.3.1 01:02:46 stop 3LA Gi0/0
*,225.1.1.1 192.168.3.1 00:13:06 never 3LA Gi0/0
HOST3#
R1
R1#show ip pim rp
Group: 225.1.1.1, RP: 4.4.4.4, uptime 00:18:37, expires 00:01:58
R1#show ip pim rp-hash 225.1.1.1
RP 4.4.4.4 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 128, holdtime 150
Uptime: 00:18:37, expires: 00:01:58
PIMv2 Hash Value (mask 0.0.0.0)
RP 4.4.4.4, via bootstrap, priority 128, hash value 1642267698
RP 1.1.1.1, via bootstrap, priority 255, hash value 332477713
R1#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
Group(s) 224.0.0.0/4
RP 4.4.4.4 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 128, holdtime 150
Uptime: 00:18:37, expires: 00:01:58
RP 1.1.1.1 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 255, holdtime 150
Uptime: 00:19:03, expires: 00:01:59
R1#show ip pim tunnel
Tunnel0
Type : PIM Encap
RP : 1.1.1.1*
Source : 1.1.1.1
State : UP
Last event : Created (00:19:03)
Tunnel2
Type : PIM Encap
RP : 4.4.4.4
Source : 10.1.4.1
State : UP
Last event : Created (00:18:37)
Tunnel1
Type : PIM Decap
RP : 1.1.1.1*
Source : -
State : UP
Last event : Created (00:19:03)
R1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.1.1, 232.0.0.1), 01:01:07/00:03:23, flags: sT
Incoming interface: GigabitEthernet2, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1, Forward/Sparse, 01:01:07/00:03:23
(*, 225.1.1.1), 00:00:19/stopped, RP 4.4.4.4, flags: SPF
Incoming interface: GigabitEthernet1, RPF nbr 10.1.4.4
Outgoing interface list: Null
(192.168.1.1, 225.1.1.1), 00:00:19/00:03:14, flags: FT
Incoming interface: GigabitEthernet2, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1, Forward/Sparse, 00:00:19/00:03:12
(*, 224.0.1.40), 01:10:50/00:02:14, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 01:10:48/00:02:14
R1#
R2
R2#show ip pim rp
Group: 225.1.1.1, RP: 4.4.4.4, uptime 00:23:06, expires 00:01:33
R2#show ip pim rp-hash 225.1.1.1
RP 4.4.4.4 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 128, holdtime 150
Uptime: 00:23:06, expires: 00:01:33
PIMv2 Hash Value (mask 0.0.0.0)
RP 4.4.4.4, via bootstrap, priority 128, hash value 1642267698
RP 1.1.1.1, via bootstrap, priority 255, hash value 332477713
R2#show ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 4.4.4.4 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 128, holdtime 150
Uptime: 00:23:06, expires: 00:01:33
RP 1.1.1.1 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 255, holdtime 150
Uptime: 00:23:32, expires: 00:01:32
R2#show ip pim tunnel
Tunnel0
Type : PIM Encap
RP : 1.1.1.1
Source : 10.2.4.2
State : UP
Last event : Created (00:23:32)
Tunnel1
Type : PIM Encap
RP : 4.4.4.4
Source : 10.2.4.2
State : UP
Last event : Created (00:23:06)
R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.1.1, 232.0.0.1), 01:05:36/00:02:23, flags: sTI
Incoming interface: GigabitEthernet1, RPF nbr 10.2.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 01:05:36/00:02:23
(*, 225.1.1.1), 00:22:41/stopped, RP 4.4.4.4, flags: SJC
Incoming interface: GigabitEthernet1, RPF nbr 10.2.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:22:41/00:02:23
(192.168.1.1, 225.1.1.1), 00:04:48/00:02:00, flags: JT
Incoming interface: GigabitEthernet1, RPF nbr 10.2.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:04:48/00:02:23
(*, 224.0.1.40), 01:14:53/00:02:08, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 01:14:51/00:02:08
R2#
R3
R3#show ip pim rp
Group: 225.1.1.1, RP: 4.4.4.4, uptime 00:19:39, expires 00:02:00
R3#show ip pim rp-hash 225.1.1.1
RP 4.4.4.4 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 128, holdtime 150
Uptime: 00:19:39, expires: 00:02:00
PIMv2 Hash Value (mask 0.0.0.0)
RP 4.4.4.4, via bootstrap, priority 128, hash value 1642267698
RP 1.1.1.1, via bootstrap, priority 255, hash value 332477713
R3#show ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 4.4.4.4 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 128, holdtime 150
Uptime: 00:19:39, expires: 00:02:00
RP 1.1.1.1 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 255, holdtime 150
Uptime: 00:20:05, expires: 00:02:01
R3#show ip pim tunnel
Tunnel0
Type : PIM Encap
RP : 1.1.1.1
Source : 10.3.4.3
State : UP
Last event : Created (00:20:05)
Tunnel1
Type : PIM Encap
RP : 4.4.4.4
Source : 10.3.4.3
State : UP
Last event : Created (00:19:39)
R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.1.1, 232.0.0.1), 00:56:38/00:02:24, flags: sTI
Incoming interface: GigabitEthernet1, RPF nbr 10.3.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:56:38/00:02:24
(*, 225.1.1.1), 00:18:58/stopped, RP 4.4.4.4, flags: SJC
Incoming interface: GigabitEthernet1, RPF nbr 10.3.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:18:58/00:02:24
(192.168.1.1, 225.1.1.1), 00:01:21/00:01:38, flags: JT
Incoming interface: GigabitEthernet1, RPF nbr 10.3.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:01:21/00:02:24
(*, 224.0.1.40), 01:10:19/00:02:43, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 01:10:17/00:02:43
R3#
R4
R4#show ip pim rp
Group: 225.1.1.1, RP: 4.4.4.4
R4#show ip pim rp-hash 225.1.1.1
RP 4.4.4.4 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 128, holdtime 150
Uptime: 00:19:51, expires: 00:01:40
PIMv2 Hash Value (mask 0.0.0.0)
RP 4.4.4.4, via bootstrap, priority 128, hash value 1642267698
RP 1.1.1.1, via bootstrap, priority 255, hash value 332477713
R4#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2)
Group(s) 224.0.0.0/4
RP 4.4.4.4 (?), v2
Info source: 4.4.4.4 (?), via bootstrap, priority 128, holdtime 150
Uptime: 00:19:51, expires: 00:01:40
RP 1.1.1.1 (?), v2
Info source: 1.1.1.1 (?), via bootstrap, priority 255, holdtime 150
Uptime: 00:20:18, expires: 00:01:32
R4#show ip pim tunnel
Tunnel0
Type : PIM Encap
RP : 1.1.1.1
Source : 10.1.4.4
State : UP
Last event : Created (00:20:18)
Tunnel2
Type : PIM Encap
RP : 4.4.4.4*
Source : 4.4.4.4
State : UP
Last event : Created (00:19:51)
Tunnel1*
Type : PIM Decap
RP : 4.4.4.4*
Source : -
State : UP
Last event : Created (00:19:51)
R4#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(192.168.1.1, 232.0.0.1), 01:02:21/00:03:00, flags: sT
Incoming interface: GigabitEthernet1, RPF nbr 10.1.4.1
Outgoing interface list:
GigabitEthernet3, Forward/Sparse, 00:56:50/00:02:44
GigabitEthernet2, Forward/Sparse, 01:02:21/00:03:00
(*, 225.1.1.1), 00:19:26/00:03:01, RP 4.4.4.4, flags: S
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet3, Forward/Sparse, 00:19:11/00:03:01
GigabitEthernet2, Forward/Sparse, 00:19:26/00:02:43
(192.168.1.1, 225.1.1.1), 00:01:33/00:01:59, flags: T
Incoming interface: GigabitEthernet1, RPF nbr 10.1.4.1
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:01:33/00:02:55
GigabitEthernet3, Forward/Sparse, 00:01:33/00:03:01
(*, 224.0.1.40), 01:09:52/00:02:13, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 01:09:50/00:02:13
R4#
hostname PE1
!
vrf definition A
rd 1:1
!
address-family ipv4
route-target export 1:1
route-target import 1:1
exit-address-family
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.4.1 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
vrf forwarding A
ip address 192.168.1.1 255.255.255.0
!
router ospf 1
router-id 10.0.0.1
passive-interface default
no passive-interface GigabitEthernet1
mpls ldp sync
mpls ldp autoconfig area 0
!
router bgp 1
bgp router-id 10.0.0.1
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.0.0.2 remote-as 1
neighbor 10.0.0.2 update-source Loopback0
neighbor 10.0.0.3 remote-as 1
neighbor 10.0.0.3 update-source Loopback0
!
address-family ipv4
exit-address-family
!
address-family vpnv4
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 send-community extended
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
exit-address-family
!
address-family ipv4 vrf A
redistribute connected
exit-address-family
!
mpls ldp router-id Loopback0
PE2
hostname PE2
!
vrf definition A
rd 1:1
!
address-family ipv4
route-target export 1:1
route-target import 1:1
exit-address-family
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.2 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.2.4.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
vrf forwarding A
ip address 192.168.2.1 255.255.255.0
!
router ospf 1
router-id 10.0.0.2
passive-interface default
no passive-interface GigabitEthernet1
mpls ldp sync
mpls ldp autoconfig area 0
!
router bgp 1
bgp router-id 10.0.0.2
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.0.0.1 remote-as 1
neighbor 10.0.0.1 update-source Loopback0
neighbor 10.0.0.3 remote-as 1
neighbor 10.0.0.3 update-source Loopback0
!
address-family ipv4
exit-address-family
!
address-family vpnv4
neighbor 10.0.0.1 activate
neighbor 10.0.0.1 send-community extended
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
exit-address-family
!
address-family ipv4 vrf A
redistribute connected
exit-address-family
!
mpls ldp router-id Loopback0
PE3
hostname PE3
!
vrf definition A
rd 1:1
!
address-family ipv4
route-target export 1:1
route-target import 1:1
exit-address-family
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.3 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.3.4.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
vrf forwarding A
ip address 192.168.3.1 255.255.255.0
!
router ospf 1
router-id 10.0.0.3
passive-interface default
no passive-interface GigabitEthernet1
mpls ldp sync
mpls ldp autoconfig area 0
!
router bgp 1
bgp router-id 10.0.0.3
bgp log-neighbor-changes
no bgp default ipv4-unicast
neighbor 10.0.0.1 remote-as 1
neighbor 10.0.0.1 update-source Loopback0
neighbor 10.0.0.2 remote-as 1
neighbor 10.0.0.2 update-source Loopback0
!
address-family ipv4
exit-address-family
!
address-family vpnv4
neighbor 10.0.0.1 activate
neighbor 10.0.0.1 send-community extended
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 send-community extended
exit-address-family
!
address-family ipv4 vrf A
redistribute connected
exit-address-family
!
mpls ldp router-id Loopback0
P1
hostname P1
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.4 255.255.255.255
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.4.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.2.4.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet3
ip address 10.3.4.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 10.0.0.4
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet2
no passive-interface GigabitEthernet3
mpls ldp sync
mpls ldp autoconfig area 0
!
mpls ldp router-id Loopback0
HOST1
hostname HOST1
!
interface GigabitEthernet0/0
ip address 192.168.1.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
HOST2
hostname HOST2
!
interface GigabitEthernet0/0
ip address 192.168.2.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.2.1
HOST3
hostname HOST1
!
interface GigabitEthernet0/0
ip address 192.168.3.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.3.1
Check connectivity
HOST1#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
HOST1#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
HOST1#
HOST2#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/2 ms
HOST2#
MVPN Configuration
PE1
vrf definition A
address-family ipv4
mdt default 232.0.0.1
mdt data 232.0.1.0 0.0.0.255 threshold 100
mdt data threshold 100
exit-address-family
!
ip multicast-routing distributed
ip multicast-routing vrf A distributed
!
interface Loopback0
ip pim sparse-mode
!
interface GigabitEthernet1
ip pim sparse-mode
!
interface GigabitEthernet2
ip pim sparse-mode
!
router bgp 1
!
address-family ipv4 mdt
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 send-community extended
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
exit-address-family
ip pim ssm default
PE2
vrf definition A
address-family ipv4
mdt default 232.0.0.1
mdt data 232.0.1.0 0.0.0.255 threshold 100
mdt data threshold 100
exit-address-family
!
ip multicast-routing distributed
ip multicast-routing vrf A distributed
!
interface Loopback0
ip pim sparse-mode
!
interface GigabitEthernet1
ip pim sparse-mode
!
interface GigabitEthernet2
ip pim sparse-mode
!
router bgp 1
!
address-family ipv4 mdt
neighbor 10.0.0.1 activate
neighbor 10.0.0.1 send-community extended
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
exit-address-family
ip pim ssm default
PE3
P1
ip multicast-routing distributed
!
interface Loopback0
ip pim sparse-mode
!
interface GigabitEthernet1
ip pim sparse-mode
!
interface GigabitEthernet2
ip pim sparse-mode
!
interface GigabitEthernet3
ip pim sparse-mode
ip pim ssm default
HOST1
interface GigabitEthernet0/0
ip igmp join-group 225.1.2.3
HOST2
interface GigabitEthernet0/0
ip igmp join-group 225.1.2.3
Multicast Verification
HOST3
HOST3#ping 225.1.2.3 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.2.3, timeout is 2 seconds:
Reply to request 0 from 192.168.1.2, 77 ms
Reply to request 0 from 192.168.2.2, 77 ms
Reply to request 1 from 192.168.1.2, 2 ms
Reply to request 1 from 192.168.2.2, 2 ms
Reply to request 2 from 192.168.1.2, 3 ms
Reply to request 2 from 192.168.2.2, 3 ms
Reply to request 3 from 192.168.1.2, 3 ms
Reply to request 3 from 192.168.2.2, 3 ms
Reply to request 4 from 192.168.2.2, 2 ms
Reply to request 4 from 192.168.1.2, 3 ms
HOST3#
Verification
PE1
PE1#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
L - DR Load-balancing Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.1.4.4 GigabitEthernet1 00:59:06/00:01:35 v2 1 / DR S P G
PE1#
PE1#
PE1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(10.0.0.3, 232.0.0.1), 00:54:30/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1, RPF nbr 10.1.4.4
Outgoing interface list:
MVRF A, Forward/Sparse, 00:54:30/00:02:29
(10.0.0.1, 232.0.0.1), 00:54:31/00:03:10, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet1, Forward/Sparse, 00:54:31/00:03:10
(10.0.0.2, 232.0.0.1), 00:54:31/stopped, flags: sTIZ
Incoming interface: GigabitEthernet1, RPF nbr 10.1.4.4
Outgoing interface list:
MVRF A, Forward/Sparse, 00:54:31/00:02:28
(*, 224.0.1.40), 01:01:14/00:02:53, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 01:01:12/00:02:53
PE1#
PE1#show ip pim vrf A neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
L - DR Load-balancing Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.0.2 Tunnel0 00:55:05/00:01:15 v2 1 / S P G
10.0.0.3 Tunnel0 00:55:05/00:01:44 v2 1 / DR S P G
PE1#
PE1#
PE1#
PE1#show tunnel endpoints Tunnel0
Tunnel0 running in multi-GRE/IP mode
Endpoint transport 232.0.0.1 Refcount 3 Base 0x7FBCF329A400 Create Time 00:58:07
overlay 232.0.0.1 Refcount 2 Parent 0x7FBCF329A400 Create Time 00:58:07
PE1#
PE1#
PE1#show ip mroute vrf A
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.1.2.3), 01:02:08/00:02:55, RP 192.168.3.1, flags: SJC
Incoming interface: Tunnel0, RPF nbr 10.0.0.3
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 01:02:08/00:02:55
(*, 224.0.1.40), 01:02:10/00:02:52, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 01:02:08/00:02:52
PE1#
PE1#show ip mroute vrf A
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 225.1.2.3), 01:03:23/stopped, RP 192.168.3.1, flags: SJC
Incoming interface: Tunnel0, RPF nbr 10.0.0.3
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 01:03:23/00:02:42
(192.168.3.2, 225.1.2.3), 00:00:08/00:02:51, flags: JT
Incoming interface: Tunnel0, RPF nbr 10.0.0.3
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:00:08/00:02:51
(*, 224.0.1.40), 01:03:25/00:02:41, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 01:03:23/00:02:41
PE1#
Efficient use of resources when there are many sources and destinations (When sources become destinations and vice versa since only (*, G) entries are created.
Designated forwarder of each segment which is elected based on unicast routing metric is used to forward traffic up and down the shared tree to avoid multicast loops since PIM-BiDir violates RPF rules
RP does not have to be a router. It only needs to be a routable address which is known as a phantom RP.
Phantom RP is usually configured by having a loopback interface with the same address but with different subnet masks on two different routers and advertise them to IGP.
Since in PIM-BiDir traffic is not sent to the RP address but traffic is passing through the RP this will result in router with more specific subnet mask becoming the RP.
If the active RP fails the router with the less specific subnet mask becomes the RP. The convergence time is equal to IGP convergence time.
In the diagram above R4 is the primary RP and R5 is configured as the secondary RP.
All three hosts are sources and destinations of the group 225.1.1.1
Device Configurations
R1
hostname R1
!
ip multicast-routing distributed
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.4.1 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.1.254 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet3
ip address 10.1.5.1 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 1.1.1.1
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet3
!
ip pim bidir-enable
R2
hostname R2
!
ip multicast-routing distributed
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.2.4.2 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.2.254 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet3
ip address 10.2.6.2 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 2.2.2.2
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet3
!
ip pim bidir-enable
R3
hostname R3
!
ip multicast-routing distributed
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.3.4.3 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 192.168.3.254 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet3
ip address 10.3.5.3 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet4
ip address 10.3.6.3 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 3.3.3.3
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet3
no passive-interface GigabitEthernet4
!
ip pim bidir-enable
R4
hostname R4
!
ip multicast-routing distributed
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface Loopback1
ip address 172.16.0.1 255.255.255.252
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.2.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet3
ip address 10.3.4.4 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 4.4.4.4
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet2
no passive-interface GigabitEthernet3
!
ip pim bidir-enable
ip pim bsr-candidate Loopback1 0
ip pim rp-candidate Loopback1 bidir
R5
hostname R5
!
interface Loopback0
ip address 5.5.5.5 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface Loopback1
ip address 172.16.0.1 255.255.255.248
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.1.5.5 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.3.5.5 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
router ospf 1
router-id 5.5.5.5
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet2
!
ip pim bidir-enable
ip pim bsr-candidate Loopback1 0
ip pim rp-candidate Loopback1 bidir
R6
hostname R6
!
interface Loopback0
ip address 6.6.6.6 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
!
interface GigabitEthernet1
ip address 10.2.6.6 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
interface GigabitEthernet2
ip address 10.3.6.6 255.255.255.0
ip pim sparse-mode
ip ospf network point-to-point
ip ospf 1 area 0
!
!
router ospf 1
router-id 6.6.6.6
passive-interface default
no passive-interface GigabitEthernet1
no passive-interface GigabitEthernet2
!
ip forward-protocol nd
ip pim bidir-enable
HOST1
interface GigabitEthernet0/0
ip address 192.168.1.1 255.255.255.0
ip igmp join-group 225.1.1.1
ip route 0.0.0.0 0.0.0.0 192.168.1.254
HOST2
interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
ip igmp join-group 225.1.1.1
ip route 0.0.0.0 0.0.0.0 192.168.2.254
HOST3
interface GigabitEthernet0/0
ip address 192.168.3.1 255.255.255.0
ip igmp join-group 225.1.1.1
ip route 0.0.0.0 0.0.0.0 192.168.3.254
Verification
HOST1
HOST1#show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
225.1.1.1 GigabitEthernet0/0 01:50:04 never 192.168.1.1
HOST1#
HOST1#
HOST1#
HOST1#ping 225.1.1.1 rep
HOST1#ping 225.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:
Reply to request 0 from 192.168.1.1, 1 ms
Reply to request 0 from 192.168.3.1, 3 ms
Reply to request 0 from 192.168.2.1, 3 ms
Reply to request 1 from 192.168.1.1, 1 ms
Reply to request 1 from 192.168.3.1, 2 ms
Reply to request 1 from 192.168.2.1, 2 ms
Reply to request 2 from 192.168.1.1, 1 ms
Reply to request 2 from 192.168.3.1, 3 ms
Reply to request 2 from 192.168.2.1, 3 ms
Reply to request 3 from 192.168.1.1, 1 ms
Reply to request 3 from 192.168.2.1, 2 ms
Reply to request 3 from 192.168.3.1, 2 ms
Reply to request 4 from 192.168.1.1, 1 ms
Reply to request 4 from 192.168.2.1, 2 ms
Reply to request 4 from 192.168.3.1, 2 ms
HOST1#
HOST2
HOST2#ping 225.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:
Reply to request 0 from 192.168.2.1, 1 ms
Reply to request 0 from 192.168.3.1, 2 ms
Reply to request 0 from 192.168.1.1, 2 ms
Reply to request 1 from 192.168.2.1, 1 ms
Reply to request 1 from 192.168.3.1, 3 ms
Reply to request 1 from 192.168.1.1, 3 ms
Reply to request 2 from 192.168.2.1, 1 ms
Reply to request 2 from 192.168.3.1, 2 ms
Reply to request 2 from 192.168.1.1, 2 ms
Reply to request 3 from 192.168.2.1, 1 ms
Reply to request 3 from 192.168.3.1, 2 ms
Reply to request 3 from 192.168.1.1, 2 ms
Reply to request 4 from 192.168.2.1, 1 ms
Reply to request 4 from 192.168.3.1, 2 ms
Reply to request 4 from 192.168.1.1, 2 ms
HOST2#
HOST3
HOST3#show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter Group Accounted
225.1.1.1 GigabitEthernet0/0 01:57:03 never 192.168.3.1
HOST3#
HOST3#
HOST3#
HOST3#ping 225.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:
Reply to request 0 from 192.168.3.1, 1 ms
Reply to request 0 from 192.168.1.1, 2 ms
Reply to request 0 from 192.168.2.1, 2 ms
Reply to request 1 from 192.168.3.1, 1 ms
Reply to request 1 from 192.168.2.1, 3 ms
Reply to request 1 from 192.168.1.1, 2 ms
Reply to request 2 from 192.168.3.1, 1 ms
Reply to request 2 from 192.168.1.1, 2 ms
Reply to request 2 from 192.168.2.1, 2 ms
Reply to request 3 from 192.168.3.1, 1 ms
Reply to request 3 from 192.168.2.1, 2 ms
Reply to request 3 from 192.168.1.1, 2 ms
Reply to request 4 from 192.168.3.1, 1 ms
Reply to request 4 from 192.168.1.1, 2 ms
Reply to request 4 from 192.168.2.1, 2 ms
HOST3#
R1
R1#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 03:01:13, expires 00:01:59
R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/3] via 10.1.4.4, 02:25:04, GigabitEthernet1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/3] via 10.1.5.5, 02:25:09, GigabitEthernet3
[110/3] via 10.1.4.4, 02:25:09, GigabitEthernet1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 10.1.4.4, 02:25:12, GigabitEthernet1
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/2] via 10.1.5.5, 02:25:11, GigabitEthernet3
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/4] via 10.1.5.5, 02:25:09, GigabitEthernet3
[110/4] via 10.1.4.4, 02:25:09, GigabitEthernet1
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.2.4.0/24 [110/2] via 10.1.4.4, 02:25:12, GigabitEthernet1
O 10.2.6.0/24 [110/3] via 10.1.4.4, 02:25:04, GigabitEthernet1
O 10.3.4.0/24 [110/2] via 10.1.4.4, 02:25:12, GigabitEthernet1
O 10.3.5.0/24 [110/2] via 10.1.5.5, 02:25:11, GigabitEthernet3
O 10.3.6.0/24 [110/3] via 10.1.5.5, 02:25:09, GigabitEthernet3
[110/3] via 10.1.4.4, 02:25:09, GigabitEthernet1
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O 172.16.0.0/29 [110/2] via 10.1.5.5, 02:25:11, GigabitEthernet3
O 172.16.0.0/30 [110/2] via 10.1.4.4, 02:25:12, GigabitEthernet1
O 192.168.2.0/24 [110/3] via 10.1.4.4, 02:25:04, GigabitEthernet1
O 192.168.3.0/24 [110/3] via 10.1.5.5, 02:25:09, GigabitEthernet3
[110/3] via 10.1.4.4, 02:25:09, GigabitEthernet1
R1#
R1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 02:24:28/-, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet1, RPF nbr: 10.1.4.4
Incoming interface list:
GigabitEthernet2, Accepting/Sparse
Loopback0, Accepting/Sparse
GigabitEthernet1, Accepting/Sparse
(*, 225.1.1.1), 02:24:28/00:02:39, RP 172.16.0.1, flags: BC
Bidir-Upstream: GigabitEthernet1, RPF nbr 10.1.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 02:24:28/00:02:39
GigabitEthernet1, Bidir-Upstream/Sparse, 02:24:28/stopped
(*, 224.0.1.40), 02:25:32/00:02:28, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:25:31/00:02:28
R1#
R1#
R2
R2#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 03:02:07, expires 00:02:05
R2#
R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/3] via 10.2.6.6, 02:26:15, GigabitEthernet3
[110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 10.2.4.4, 02:26:14, GigabitEthernet1
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/4] via 10.2.6.6, 02:26:15, GigabitEthernet3
[110/4] via 10.2.4.4, 02:26:14, GigabitEthernet1
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/2] via 10.2.6.6, 02:26:15, GigabitEthernet3
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.1.4.0/24 [110/2] via 10.2.4.4, 02:26:14, GigabitEthernet1
O 10.1.5.0/24 [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
O 10.3.4.0/24 [110/2] via 10.2.4.4, 02:26:14, GigabitEthernet1
O 10.3.5.0/24 [110/3] via 10.2.6.6, 02:26:15, GigabitEthernet3
[110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
O 10.3.6.0/24 [110/2] via 10.2.6.6, 02:26:15, GigabitEthernet3
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O 172.16.0.0/29 [110/4] via 10.2.6.6, 02:26:15, GigabitEthernet3
[110/4] via 10.2.4.4, 02:26:14, GigabitEthernet1
O 172.16.0.0/30 [110/2] via 10.2.4.4, 02:26:14, GigabitEthernet1
O 192.168.1.0/24 [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
O 192.168.3.0/24 [110/3] via 10.2.6.6, 02:26:15, GigabitEthernet3
[110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
R2#
R2#
R2#
R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 02:25:31/-, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet1, RPF nbr: 10.2.4.4
Incoming interface list:
GigabitEthernet2, Accepting/Sparse
GigabitEthernet3, Accepting/Sparse
Loopback0, Accepting/Sparse
GigabitEthernet1, Accepting/Sparse
(*, 225.1.1.1), 02:25:31/00:02:31, RP 172.16.0.1, flags: BC
Bidir-Upstream: GigabitEthernet1, RPF nbr 10.2.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 02:25:31/00:02:31
GigabitEthernet1, Bidir-Upstream/Sparse, 02:25:31/stopped
(*, 224.0.1.40), 02:26:32/00:02:32, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:26:31/00:02:32
R2#
R3
R3#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 03:02:56, expires 00:02:19
R3#
R3#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/3] via 10.3.5.5, 02:27:07, GigabitEthernet3
[110/3] via 10.3.4.4, 02:27:07, GigabitEthernet1
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/3] via 10.3.6.6, 02:27:04, GigabitEthernet4
[110/3] via 10.3.4.4, 02:27:01, GigabitEthernet1
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/2] via 10.3.4.4, 02:27:07, GigabitEthernet1
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/2] via 10.3.5.5, 02:27:07, GigabitEthernet3
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/2] via 10.3.6.6, 02:27:06, GigabitEthernet4
10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O 10.1.4.0/24 [110/2] via 10.3.4.4, 02:27:07, GigabitEthernet1
O 10.1.5.0/24 [110/2] via 10.3.5.5, 02:27:07, GigabitEthernet3
O 10.2.4.0/24 [110/2] via 10.3.4.4, 02:27:07, GigabitEthernet1
O 10.2.6.0/24 [110/2] via 10.3.6.6, 02:27:06, GigabitEthernet4
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O 172.16.0.0/29 [110/2] via 10.3.5.5, 02:27:07, GigabitEthernet3
O 172.16.0.0/30 [110/2] via 10.3.4.4, 02:27:07, GigabitEthernet1
O 192.168.1.0/24 [110/3] via 10.3.5.5, 02:27:07, GigabitEthernet3
[110/3] via 10.3.4.4, 02:27:07, GigabitEthernet1
O 192.168.2.0/24 [110/3] via 10.3.6.6, 02:27:04, GigabitEthernet4
[110/3] via 10.3.4.4, 02:27:01, GigabitEthernet1
R3#
R3#
R3#
R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 02:26:22/-, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet1, RPF nbr: 10.3.4.4
Incoming interface list:
GigabitEthernet4, Accepting/Sparse
GigabitEthernet2, Accepting/Sparse
Loopback0, Accepting/Sparse
GigabitEthernet1, Accepting/Sparse
(*, 225.1.1.1), 02:26:21/00:02:43, RP 172.16.0.1, flags: BC
Bidir-Upstream: GigabitEthernet1, RPF nbr 10.3.4.4
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 02:26:21/00:02:43
GigabitEthernet1, Bidir-Upstream/Sparse, 02:26:21/stopped
(*, 224.0.1.40), 02:27:24/00:02:40, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:27:23/00:02:40
R3#
R4
R4#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1
R4#
R4#
R4#
R4#show ip route connected
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C 10.1.4.0/24 is directly connected, GigabitEthernet1
L 10.1.4.4/32 is directly connected, GigabitEthernet1
C 10.2.4.0/24 is directly connected, GigabitEthernet2
L 10.2.4.4/32 is directly connected, GigabitEthernet2
C 10.3.4.0/24 is directly connected, GigabitEthernet3
L 10.3.4.4/32 is directly connected, GigabitEthernet3
172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C 172.16.0.0/30 is directly connected, Loopback1
L 172.16.0.1/32 is directly connected, Loopback1
R4#
R4#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 10.1.4.1, 02:48:03, GigabitEthernet1
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 10.2.4.2, 02:47:59, GigabitEthernet2
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 10.3.4.3, 02:48:01, GigabitEthernet3
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/3] via 10.3.4.3, 02:47:59, GigabitEthernet3
[110/3] via 10.1.4.1, 02:48:01, GigabitEthernet1
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/3] via 10.3.4.3, 02:48:01, GigabitEthernet3
[110/3] via 10.2.4.2, 02:47:59, GigabitEthernet2
10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O 10.1.5.0/24 [110/2] via 10.1.4.1, 02:48:03, GigabitEthernet1
O 10.2.6.0/24 [110/2] via 10.2.4.2, 02:47:59, GigabitEthernet2
O 10.3.5.0/24 [110/2] via 10.3.4.3, 02:48:01, GigabitEthernet3
O 10.3.6.0/24 [110/2] via 10.3.4.3, 02:48:01, GigabitEthernet3
172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
O 172.16.0.0/29 [110/3] via 10.3.4.3, 02:47:59, GigabitEthernet3
[110/3] via 10.1.4.1, 02:48:01, GigabitEthernet1
O 192.168.1.0/24 [110/2] via 10.1.4.1, 02:48:03, GigabitEthernet1
O 192.168.2.0/24 [110/2] via 10.2.4.2, 02:47:59, GigabitEthernet2
O 192.168.3.0/24 [110/2] via 10.3.4.3, 02:48:01, GigabitEthernet3
R4#
R4#
R4#
R4#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 02:48:19/-, RP 172.16.0.1, flags: B
Bidir-Upstream: Loopback1, RPF nbr: 172.16.0.1
Incoming interface list:
GigabitEthernet3, Accepting/Sparse
GigabitEthernet2, Accepting/Sparse
GigabitEthernet1, Accepting/Sparse
Loopback0, Accepting/Sparse
Loopback1, Accepting/Sparse
(*, 225.1.1.1), 02:47:18/00:03:23, RP 172.16.0.1, flags: B
Bidir-Upstream: Null, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 02:47:18/00:03:23
GigabitEthernet3, Forward/Sparse, 02:47:18/00:02:33
GigabitEthernet1, Forward/Sparse, 02:47:18/00:02:37
(*, 224.0.1.40), 02:48:19/00:02:42, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:48:18/00:02:42
R4#
R5
R5#show ip pim rp
R5#
R5#
R5#
R5#show ip pim rp map
R5#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2)
Group(s) 224.0.0.0/4
RP 172.16.0.1 (?), v2, bidir
Info source: 172.16.0.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 03:08:21, expires: 00:02:06
R5#
R5#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 10.1.5.1, 02:48:44, GigabitEthernet1
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/4] via 10.3.5.3, 02:48:40, GigabitEthernet2
[110/4] via 10.1.5.1, 02:48:36, GigabitEthernet1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 10.3.5.3, 02:48:42, GigabitEthernet2
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/3] via 10.3.5.3, 02:48:42, GigabitEthernet2
[110/3] via 10.1.5.1, 02:48:44, GigabitEthernet1
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/3] via 10.3.5.3, 02:48:41, GigabitEthernet2
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.1.4.0/24 [110/2] via 10.1.5.1, 02:48:44, GigabitEthernet1
O 10.2.4.0/24 [110/3] via 10.3.5.3, 02:48:42, GigabitEthernet2
[110/3] via 10.1.5.1, 02:48:44, GigabitEthernet1
O 10.2.6.0/24 [110/3] via 10.3.5.3, 02:48:41, GigabitEthernet2
O 10.3.4.0/24 [110/2] via 10.3.5.3, 02:48:42, GigabitEthernet2
O 10.3.6.0/24 [110/2] via 10.3.5.3, 02:48:42, GigabitEthernet2
172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
O 172.16.0.0/30 [110/3] via 10.3.5.3, 02:48:42, GigabitEthernet2
[110/3] via 10.1.5.1, 02:48:44, GigabitEthernet1
O 192.168.1.0/24 [110/2] via 10.1.5.1, 02:48:44, GigabitEthernet1
O 192.168.2.0/24 [110/4] via 10.3.5.3, 02:48:40, GigabitEthernet2
[110/4] via 10.1.5.1, 02:48:36, GigabitEthernet1
O 192.168.3.0/24 [110/2] via 10.3.5.3, 02:48:42, GigabitEthernet2
R5#
R5#
R5#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 02:48:58/-, RP 172.16.0.1, flags: B
Bidir-Upstream: Loopback1, RPF nbr: 172.16.0.1
Incoming interface list:
GigabitEthernet2, Accepting/Sparse
GigabitEthernet1, Accepting/Sparse
Loopback0, Accepting/Sparse
Loopback1, Accepting/Sparse
(*, 224.0.1.40), 02:48:58/00:02:02, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:48:57/00:02:02
R5#
R6
R6#show ip pim rp
R6#
R6#
R6#
R6#show ip pim rp map
R6#show ip pim rp mapping
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
RP 172.16.0.1 (?), v2, bidir
Info source: 172.16.0.1 (?), via bootstrap, priority 0, holdtime 150
Uptime: 03:08:18, expires: 00:01:58
R6#
R6#
R6#
R6#
R6#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/4] via 10.3.6.3, 02:49:22, GigabitEthernet2
[110/4] via 10.2.6.2, 02:49:21, GigabitEthernet1
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 10.2.6.2, 02:49:21, GigabitEthernet1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 10.3.6.3, 02:49:22, GigabitEthernet2
4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
[110/3] via 10.2.6.2, 02:49:21, GigabitEthernet1
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.1.4.0/24 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
[110/3] via 10.2.6.2, 02:49:21, GigabitEthernet1
O 10.1.5.0/24 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
O 10.2.4.0/24 [110/2] via 10.2.6.2, 02:49:21, GigabitEthernet1
O 10.3.4.0/24 [110/2] via 10.3.6.3, 02:49:22, GigabitEthernet2
O 10.3.5.0/24 [110/2] via 10.3.6.3, 02:49:22, GigabitEthernet2
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O 172.16.0.0/29 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
O 172.16.0.0/30 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
[110/3] via 10.2.6.2, 02:49:21, GigabitEthernet1
O 192.168.1.0/24 [110/4] via 10.3.6.3, 02:49:22, GigabitEthernet2
[110/4] via 10.2.6.2, 02:49:21, GigabitEthernet1
O 192.168.2.0/24 [110/2] via 10.2.6.2, 02:49:21, GigabitEthernet1
O 192.168.3.0/24 [110/2] via 10.3.6.3, 02:49:22, GigabitEthernet2
R6#
R6#
R6#
R6#
R6#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 02:48:38/-, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet2, RPF nbr: 10.3.6.3
Incoming interface list:
Loopback0, Accepting/Sparse
GigabitEthernet2, Accepting/Sparse
(*, 224.0.1.40), 02:49:40/00:02:22, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:49:39/00:02:22
R6#
RP Failure
R1
R1#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 02:52:37, expires 00:01:59
R1#
R1#
R1#
R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/5] via 10.1.5.5, 00:02:13, GigabitEthernet3
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/3] via 10.1.5.5, 02:53:30, GigabitEthernet3
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/2] via 10.1.5.5, 02:53:32, GigabitEthernet3
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/4] via 10.1.5.5, 02:53:30, GigabitEthernet3
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.2.4.0/24 [110/5] via 10.1.5.5, 00:02:12, GigabitEthernet3
O 10.2.6.0/24 [110/4] via 10.1.5.5, 00:02:13, GigabitEthernet3
O 10.3.4.0/24 [110/3] via 10.1.5.5, 00:02:13, GigabitEthernet3
O 10.3.5.0/24 [110/2] via 10.1.5.5, 02:53:32, GigabitEthernet3
O 10.3.6.0/24 [110/3] via 10.1.5.5, 02:53:30, GigabitEthernet3
172.16.0.0/29 is subnetted, 1 subnets
O 172.16.0.0 [110/2] via 10.1.5.5, 02:53:32, GigabitEthernet3
O 192.168.2.0/24 [110/5] via 10.1.5.5, 00:02:13, GigabitEthernet3
O 192.168.3.0/24 [110/3] via 10.1.5.5, 02:53:30, GigabitEthernet3
R1#
R1#
R1#
R1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 00:02:16/-, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet3, RPF nbr: 10.1.5.5
Incoming interface list:
GigabitEthernet3, Accepting/Sparse
GigabitEthernet1, Accepting/Sparse
GigabitEthernet2, Accepting/Sparse
Loopback0, Accepting/Sparse
(*, 225.1.1.1), 02:52:49/00:02:11, RP 172.16.0.1, flags: BC
Bidir-Upstream: GigabitEthernet3, RPF nbr 10.1.5.5
Outgoing interface list:
GigabitEthernet3, Bidir-Upstream/Sparse, 00:02:19/stopped
GigabitEthernet2, Forward/Sparse, 02:52:49/00:02:11
(*, 224.0.1.40), 02:53:53/00:02:13, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:53:52/00:02:13
R1#
R2
R2#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 02:53:26, expires 00:02:12
R2#
R2#
R2#
R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/5] via 10.2.6.6, 00:03:02, GigabitEthernet3
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/3] via 10.2.6.6, 02:54:19, GigabitEthernet3
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/4] via 10.2.6.6, 02:54:19, GigabitEthernet3
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/2] via 10.2.6.6, 02:54:19, GigabitEthernet3
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.1.4.0/24 [110/5] via 10.2.6.6, 00:02:58, GigabitEthernet3
O 10.1.5.0/24 [110/4] via 10.2.6.6, 00:03:02, GigabitEthernet3
O 10.3.4.0/24 [110/3] via 10.2.6.6, 00:02:58, GigabitEthernet3
O 10.3.5.0/24 [110/3] via 10.2.6.6, 02:54:19, GigabitEthernet3
O 10.3.6.0/24 [110/2] via 10.2.6.6, 02:54:19, GigabitEthernet3
172.16.0.0/29 is subnetted, 1 subnets
O 172.16.0.0 [110/4] via 10.2.6.6, 02:54:19, GigabitEthernet3
O 192.168.1.0/24 [110/5] via 10.2.6.6, 00:03:02, GigabitEthernet3
O 192.168.3.0/24 [110/3] via 10.2.6.6, 02:54:19, GigabitEthernet3
R2#
R2#
R2#
R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 00:03:03/-, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet3, RPF nbr: 10.2.6.6
Incoming interface list:
GigabitEthernet1, Accepting/Sparse
GigabitEthernet3, Accepting/Sparse
GigabitEthernet2, Accepting/Sparse
Loopback0, Accepting/Sparse
(*, 225.1.1.1), 02:53:36/00:02:34, RP 172.16.0.1, flags: BC
Bidir-Upstream: GigabitEthernet3, RPF nbr 10.2.6.6
Outgoing interface list:
GigabitEthernet3, Bidir-Upstream/Sparse, 00:03:03/stopped
GigabitEthernet2, Forward/Sparse, 02:53:36/00:02:34
(*, 224.0.1.40), 02:54:37/00:02:26, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:54:36/00:02:26
R2#
R3
R3#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 02:54:14, expires 00:02:24
R3#
R3#
R3#
R3#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/3] via 10.3.5.5, 02:55:07, GigabitEthernet3
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/3] via 10.3.6.6, 02:55:04, GigabitEthernet4
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/2] via 10.3.5.5, 02:55:07, GigabitEthernet3
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/2] via 10.3.6.6, 02:55:06, GigabitEthernet4
10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O 10.1.4.0/24 [110/3] via 10.3.5.5, 00:03:47, GigabitEthernet3
O 10.1.5.0/24 [110/2] via 10.3.5.5, 02:55:07, GigabitEthernet3
O 10.2.4.0/24 [110/3] via 10.3.6.6, 00:03:47, GigabitEthernet4
O 10.2.6.0/24 [110/2] via 10.3.6.6, 02:55:06, GigabitEthernet4
172.16.0.0/29 is subnetted, 1 subnets
O 172.16.0.0 [110/2] via 10.3.5.5, 02:55:07, GigabitEthernet3
O 192.168.1.0/24 [110/3] via 10.3.5.5, 02:55:07, GigabitEthernet3
O 192.168.2.0/24 [110/3] via 10.3.6.6, 02:55:04, GigabitEthernet4
R3#
R3#
R3#
R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 00:03:50/-, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet3, RPF nbr: 10.3.5.5
Incoming interface list:
GigabitEthernet4, Accepting/Sparse
GigabitEthernet3, Accepting/Sparse
GigabitEthernet1, Accepting/Sparse
GigabitEthernet2, Accepting/Sparse
Loopback0, Accepting/Sparse
(*, 225.1.1.1), 02:54:23/00:02:46, RP 172.16.0.1, flags: BC
Bidir-Upstream: GigabitEthernet3, RPF nbr 10.3.5.5
Outgoing interface list:
GigabitEthernet4, Forward/Sparse, 00:03:50/00:02:33
GigabitEthernet3, Bidir-Upstream/Sparse, 00:03:50/stopped
GigabitEthernet2, Forward/Sparse, 02:54:23/00:02:46
(*, 224.0.1.40), 02:55:26/00:02:42, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:55:25/00:02:42
R3#
R5
R5#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1
R5#
R5#
R5#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/2] via 10.1.5.1, 02:56:06, GigabitEthernet1
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/4] via 10.3.5.3, 02:56:02, GigabitEthernet2
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 10.3.5.3, 02:56:04, GigabitEthernet2
6.0.0.0/32 is subnetted, 1 subnets
O 6.6.6.6 [110/3] via 10.3.5.3, 02:56:03, GigabitEthernet2
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.1.4.0/24 [110/2] via 10.1.5.1, 02:56:06, GigabitEthernet1
O 10.2.4.0/24 [110/4] via 10.3.5.3, 00:04:45, GigabitEthernet2
O 10.2.6.0/24 [110/3] via 10.3.5.3, 02:56:03, GigabitEthernet2
O 10.3.4.0/24 [110/2] via 10.3.5.3, 02:56:04, GigabitEthernet2
O 10.3.6.0/24 [110/2] via 10.3.5.3, 02:56:04, GigabitEthernet2
O 192.168.1.0/24 [110/2] via 10.1.5.1, 02:56:06, GigabitEthernet1
O 192.168.2.0/24 [110/4] via 10.3.5.3, 02:56:02, GigabitEthernet2
O 192.168.3.0/24 [110/2] via 10.3.5.3, 02:56:04, GigabitEthernet2
R5#
R5#show ip route connected
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
5.0.0.0/32 is subnetted, 1 subnets
C 5.5.5.5 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
C 10.1.5.0/24 is directly connected, GigabitEthernet1
L 10.1.5.5/32 is directly connected, GigabitEthernet1
C 10.3.5.0/24 is directly connected, GigabitEthernet2
L 10.3.5.5/32 is directly connected, GigabitEthernet2
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 172.16.0.0/29 is directly connected, Loopback1
L 172.16.0.1/32 is directly connected, Loopback1
R5#
R5#
R5#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 02:56:33/-, RP 172.16.0.1, flags: B
Bidir-Upstream: Loopback1, RPF nbr: 172.16.0.1
Incoming interface list:
GigabitEthernet2, Accepting/Sparse
GigabitEthernet1, Accepting/Sparse
Loopback0, Accepting/Sparse
Loopback1, Accepting/Sparse
(*, 225.1.1.1), 00:05:02/00:03:15, RP 172.16.0.1, flags: B
Bidir-Upstream: Null, RPF nbr 0.0.0.0
Outgoing interface list:
GigabitEthernet2, Forward/Sparse, 00:04:59/00:03:13
GigabitEthernet1, Forward/Sparse, 00:05:02/00:03:15
(*, 224.0.1.40), 02:56:33/00:02:27, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:56:32/00:02:27
R5#
R6
R6#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 02:56:06, expires 00:01:32
R6#
R6#
R6#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
H - NHRP, G - NHRP registered, g - NHRP registration summary
o - ODR, P - periodic downloaded static route, l - LISP
a - application route
+ - replicated route, % - next hop override, p - overrides from PfR
& - replicated local route overrides by connected
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/4] via 10.3.6.3, 02:56:59, GigabitEthernet2
2.0.0.0/32 is subnetted, 1 subnets
O 2.2.2.2 [110/2] via 10.2.6.2, 02:56:58, GigabitEthernet1
3.0.0.0/32 is subnetted, 1 subnets
O 3.3.3.3 [110/2] via 10.3.6.3, 02:56:59, GigabitEthernet2
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/3] via 10.3.6.3, 02:56:59, GigabitEthernet2
10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 10.1.4.0/24 [110/4] via 10.3.6.3, 00:05:38, GigabitEthernet2
O 10.1.5.0/24 [110/3] via 10.3.6.3, 02:56:59, GigabitEthernet2
O 10.2.4.0/24 [110/2] via 10.2.6.2, 02:56:58, GigabitEthernet1
O 10.3.4.0/24 [110/2] via 10.3.6.3, 02:56:59, GigabitEthernet2
O 10.3.5.0/24 [110/2] via 10.3.6.3, 02:56:59, GigabitEthernet2
172.16.0.0/29 is subnetted, 1 subnets
O 172.16.0.0 [110/3] via 10.3.6.3, 02:56:59, GigabitEthernet2
O 192.168.1.0/24 [110/4] via 10.3.6.3, 02:56:59, GigabitEthernet2
O 192.168.2.0/24 [110/2] via 10.2.6.2, 02:56:58, GigabitEthernet1
O 192.168.3.0/24 [110/2] via 10.3.6.3, 02:56:59, GigabitEthernet2
R6#
R6#
R6#
R6#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
Q - Received BGP S-A Route, q - Sent BGP S-A Route,
V - RD & Vector, v - Vector, p - PIM Joins on route,
x - VxLAN group, c - PFP-SA cache created entry,
* - determined by Assert, # - iif-starg configured on rpf intf,
e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*,224.0.0.0/4), 00:05:42/-, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet2, RPF nbr: 10.3.6.3
Incoming interface list:
GigabitEthernet1, Accepting/Sparse
GigabitEthernet2, Accepting/Sparse
Loopback0, Accepting/Sparse
(*, 225.1.1.1), 00:05:43/00:03:19, RP 172.16.0.1, flags: B
Bidir-Upstream: GigabitEthernet2, RPF nbr 10.3.6.3
Outgoing interface list:
GigabitEthernet1, Forward/Sparse, 00:05:41/00:03:19
GigabitEthernet2, Bidir-Upstream/Sparse, 00:05:42/stopped
(*, 224.0.1.40), 02:57:17/00:02:45, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
Loopback0, Forward/Sparse, 02:57:16/00:02:45
R6#