MVPN Profile 0: Cisco IOS-XE

Topology

Unicast L3VPN Configuration

PE1

hostname PE1
!
vrf definition A
 rd 1:1
 !
 address-family ipv4
  route-target export 1:1
  route-target import 1:1
 exit-address-family
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.1.4.1 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
 !
interface GigabitEthernet2
 vrf forwarding A
 ip address 192.168.1.1 255.255.255.0
 !
router ospf 1
 router-id 10.0.0.1
 passive-interface default
 no passive-interface GigabitEthernet1
 mpls ldp sync
 mpls ldp autoconfig area 0
!
router bgp 1
 bgp router-id 10.0.0.1
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 10.0.0.2 remote-as 1
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.3 remote-as 1
 neighbor 10.0.0.3 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.2 send-community extended
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.3 send-community extended
 exit-address-family
  !
 address-family ipv4 vrf A
  redistribute connected
 exit-address-family
!
mpls ldp router-id Loopback0

PE2

hostname PE2
!
vrf definition A
 rd 1:1
 !
 address-family ipv4
  route-target export 1:1
  route-target import 1:1
 exit-address-family
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.255
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.2.4.2 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet2
 vrf forwarding A
 ip address 192.168.2.1 255.255.255.0
!
router ospf 1
 router-id 10.0.0.2
 passive-interface default
 no passive-interface GigabitEthernet1
 mpls ldp sync
 mpls ldp autoconfig area 0
!
router bgp 1
 bgp router-id 10.0.0.2
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 10.0.0.1 remote-as 1
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.3 remote-as 1
 neighbor 10.0.0.3 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community extended
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.3 send-community extended
 exit-address-family
  !
 address-family ipv4 vrf A
  redistribute connected
 exit-address-family
!
mpls ldp router-id Loopback0

PE3

hostname PE3
!
vrf definition A
 rd 1:1
 !
 address-family ipv4
  route-target export 1:1
  route-target import 1:1
 exit-address-family
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.3 255.255.255.255
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.3.4.3 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
 !
interface GigabitEthernet2
 vrf forwarding A
 ip address 192.168.3.1 255.255.255.0
 !
router ospf 1
 router-id 10.0.0.3
 passive-interface default
 no passive-interface GigabitEthernet1
 mpls ldp sync
 mpls ldp autoconfig area 0
!
router bgp 1
 bgp router-id 10.0.0.3
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 10.0.0.1 remote-as 1
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.2 remote-as 1
 neighbor 10.0.0.2 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community extended
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.2 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf A
  redistribute connected
 exit-address-family
!
mpls ldp router-id Loopback0

P1

hostname P1
!
no ip domain lookup
!
mpls label protocol ldp
!
interface Loopback0
 ip address 10.0.0.4 255.255.255.255
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.1.4.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet2
 ip address 10.2.4.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet3
 ip address 10.3.4.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 0
!
router ospf 1
 router-id 10.0.0.4
 passive-interface default
 no passive-interface GigabitEthernet1
 no passive-interface GigabitEthernet2
 no passive-interface GigabitEthernet3
 mpls ldp sync
 mpls ldp autoconfig area 0
!
mpls ldp router-id Loopback0

HOST1

hostname HOST1
!
interface GigabitEthernet0/0
 ip address 192.168.1.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1

HOST2

hostname HOST2
!
interface GigabitEthernet0/0
 ip address 192.168.2.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.2.1

HOST3

hostname HOST1
!
interface GigabitEthernet0/0
 ip address 192.168.3.2 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 192.168.3.1

Check connectivity

HOST1#ping 192.168.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
HOST1#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms
HOST1#

HOST2#ping 192.168.3.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.3.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/2 ms
HOST2#

MVPN Configuration

PE1


vrf definition A
 
 address-family ipv4
  mdt default 232.0.0.1
  mdt data 232.0.1.0 0.0.0.255 threshold 100
  mdt data threshold 100
  
 exit-address-family

!
ip multicast-routing distributed
ip multicast-routing vrf A distributed
!
interface Loopback0
 ip pim sparse-mode
 !
interface GigabitEthernet1
 ip pim sparse-mode
 !
interface GigabitEthernet2
 ip pim sparse-mode
!
router bgp 1
 !
 address-family ipv4 mdt
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.2 send-community extended
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.3 send-community extended
 exit-address-family
 
ip pim ssm default

PE2


vrf definition A
 
 address-family ipv4
  mdt default 232.0.0.1
  mdt data 232.0.1.0 0.0.0.255 threshold 100
  mdt data threshold 100
  
 exit-address-family

!
ip multicast-routing distributed
ip multicast-routing vrf A distributed
!
interface Loopback0
 ip pim sparse-mode
 !
interface GigabitEthernet1
 ip pim sparse-mode
 !
interface GigabitEthernet2
 ip pim sparse-mode
!
router bgp 1
 !
 address-family ipv4 mdt
  neighbor 10.0.0.1 activate
  neighbor 10.0.0.1 send-community extended
  neighbor 10.0.0.3 activate
  neighbor 10.0.0.3 send-community extended
 exit-address-family
 
ip pim ssm default

PE3

P1

ip multicast-routing distributed
!
interface Loopback0
 ip pim sparse-mode
 !
interface GigabitEthernet1
 ip pim sparse-mode
 !
interface GigabitEthernet2
 ip pim sparse-mode
!
interface GigabitEthernet3
 ip pim sparse-mode

ip pim ssm default

HOST1

interface GigabitEthernet0/0
 ip igmp join-group 225.1.2.3

HOST2

interface GigabitEthernet0/0
 ip igmp join-group 225.1.2.3

Multicast Verification

HOST3

HOST3#ping 225.1.2.3 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.2.3, timeout is 2 seconds:

Reply to request 0 from 192.168.1.2, 77 ms
Reply to request 0 from 192.168.2.2, 77 ms
Reply to request 1 from 192.168.1.2, 2 ms
Reply to request 1 from 192.168.2.2, 2 ms
Reply to request 2 from 192.168.1.2, 3 ms
Reply to request 2 from 192.168.2.2, 3 ms
Reply to request 3 from 192.168.1.2, 3 ms
Reply to request 3 from 192.168.2.2, 3 ms
Reply to request 4 from 192.168.2.2, 2 ms
Reply to request 4 from 192.168.1.2, 3 ms
HOST3#

Verification

PE1

PE1#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
      L - DR Load-balancing Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.1.4.4          GigabitEthernet1         00:59:06/00:01:35 v2    1 / DR S P G
PE1#
PE1#
PE1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(10.0.0.3, 232.0.0.1), 00:54:30/stopped, flags: sTIZ
  Incoming interface: GigabitEthernet1, RPF nbr 10.1.4.4
  Outgoing interface list:
    MVRF A, Forward/Sparse, 00:54:30/00:02:29

(10.0.0.1, 232.0.0.1), 00:54:31/00:03:10, flags: sT
  Incoming interface: Loopback0, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet1, Forward/Sparse, 00:54:31/00:03:10

(10.0.0.2, 232.0.0.1), 00:54:31/stopped, flags: sTIZ
  Incoming interface: GigabitEthernet1, RPF nbr 10.1.4.4
  Outgoing interface list:
    MVRF A, Forward/Sparse, 00:54:31/00:02:28

(*, 224.0.1.40), 01:01:14/00:02:53, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 01:01:12/00:02:53

PE1#
PE1#show ip pim vrf A neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
      L - DR Load-balancing Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.0.2          Tunnel0                  00:55:05/00:01:15 v2    1 / S P G
10.0.0.3          Tunnel0                  00:55:05/00:01:44 v2    1 / DR S P G
PE1#
PE1#
PE1#
PE1#show tunnel endpoints Tunnel0
 Tunnel0 running in multi-GRE/IP mode

 Endpoint transport 232.0.0.1 Refcount 3 Base 0x7FBCF329A400 Create Time 00:58:07
   overlay 232.0.0.1 Refcount 2 Parent 0x7FBCF329A400 Create Time 00:58:07
PE1#
PE1#
PE1#show ip mroute vrf A
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.1.2.3), 01:02:08/00:02:55, RP 192.168.3.1, flags: SJC
  Incoming interface: Tunnel0, RPF nbr 10.0.0.3
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 01:02:08/00:02:55

(*, 224.0.1.40), 01:02:10/00:02:52, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 01:02:08/00:02:52

PE1#
PE1#show ip mroute vrf A
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.1.2.3), 01:03:23/stopped, RP 192.168.3.1, flags: SJC
  Incoming interface: Tunnel0, RPF nbr 10.0.0.3
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 01:03:23/00:02:42

(192.168.3.2, 225.1.2.3), 00:00:08/00:02:51, flags: JT
  Incoming interface: Tunnel0, RPF nbr 10.0.0.3
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 00:00:08/00:02:51

(*, 224.0.1.40), 01:03:25/00:02:41, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 01:03:23/00:02:41

PE1#