PIM Bi-Dir: Cisco IOS

Summary

  1. PIM-BiDir creates only a shared tree
  2. Efficient use of resources when there are many sources and destinations (When sources become destinations and vice versa since only (*, G) entries are created.
  3. Designated forwarder of each segment which is elected based on unicast routing metric is used to forward traffic up and down the shared tree to avoid multicast loops since PIM-BiDir violates RPF rules
  4. RP does not have to be a router. It only needs to be a routable address which is known as a phantom RP.
  5. Phantom RP is usually configured by having a loopback interface with the same address but with different subnet masks on two different routers and advertise them to IGP.
  6. Since in PIM-BiDir traffic is not sent to the RP address but traffic is passing through the RP this will result in router with more specific subnet mask becoming the RP.
  7. If the active RP fails the router with the less specific subnet mask becomes the RP. The convergence time is equal to IGP convergence time.
  8. In the diagram above R4 is the primary RP and R5 is configured as the secondary RP.
  9. All three hosts are sources and destinations of the group 225.1.1.1

Device Configurations

R1

hostname R1
!
ip multicast-routing distributed
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.1.4.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet2
 ip address 192.168.1.254 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet3
 ip address 10.1.5.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!

router ospf 1
 router-id 1.1.1.1
 passive-interface default
 no passive-interface GigabitEthernet1
 no passive-interface GigabitEthernet3
!
ip pim bidir-enable

R2

hostname R2
!
ip multicast-routing distributed
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.2.4.2 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet2
 ip address 192.168.2.254 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet3
 ip address 10.2.6.2 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
router ospf 1
 router-id 2.2.2.2
 passive-interface default
 no passive-interface GigabitEthernet1
 no passive-interface GigabitEthernet3
!
ip pim bidir-enable

R3

hostname R3
!
ip multicast-routing distributed
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.3.4.3 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet2
 ip address 192.168.3.254 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet3
 ip address 10.3.5.3 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet4
 ip address 10.3.6.3 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
router ospf 1
 router-id 3.3.3.3
 passive-interface default
 no passive-interface GigabitEthernet1
 no passive-interface GigabitEthernet3
 no passive-interface GigabitEthernet4
!
ip pim bidir-enable

R4

hostname R4
!
ip multicast-routing distributed
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface Loopback1
 ip address 172.16.0.1 255.255.255.252
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.1.4.4 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet2
 ip address 10.2.4.4 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet3
 ip address 10.3.4.4 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
router ospf 1
 router-id 4.4.4.4
 passive-interface default
 no passive-interface GigabitEthernet1
 no passive-interface GigabitEthernet2
 no passive-interface GigabitEthernet3
!
ip pim bidir-enable
ip pim bsr-candidate Loopback1 0
ip pim rp-candidate Loopback1 bidir

R5

hostname R5
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface Loopback1
 ip address 172.16.0.1 255.255.255.248
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.1.5.5 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet2
 ip address 10.3.5.5 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
router ospf 1
 router-id 5.5.5.5
 passive-interface default
 no passive-interface GigabitEthernet1
 no passive-interface GigabitEthernet2
!
ip pim bidir-enable
ip pim bsr-candidate Loopback1 0
ip pim rp-candidate Loopback1 bidir

R6

hostname R6
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
 ip pim sparse-mode
 ip ospf 1 area 0
!
interface GigabitEthernet1
 ip address 10.2.6.6 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface GigabitEthernet2
 ip address 10.3.6.6 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
!
router ospf 1
 router-id 6.6.6.6
 passive-interface default
 no passive-interface GigabitEthernet1
 no passive-interface GigabitEthernet2
!
ip forward-protocol nd
ip pim bidir-enable

HOST1

interface GigabitEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip igmp join-group 225.1.1.1

ip route 0.0.0.0 0.0.0.0 192.168.1.254

HOST2

interface GigabitEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 ip igmp join-group 225.1.1.1

ip route 0.0.0.0 0.0.0.0 192.168.2.254

HOST3

interface GigabitEthernet0/0
 ip address 192.168.3.1 255.255.255.0
 ip igmp join-group 225.1.1.1

ip route 0.0.0.0 0.0.0.0 192.168.3.254

Verification

HOST1

HOST1#show ip igmp groups
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
225.1.1.1        GigabitEthernet0/0       01:50:04  never     192.168.1.1
HOST1#
HOST1#
HOST1#
HOST1#ping 225.1.1.1 rep
HOST1#ping 225.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:

Reply to request 0 from 192.168.1.1, 1 ms
Reply to request 0 from 192.168.3.1, 3 ms
Reply to request 0 from 192.168.2.1, 3 ms
Reply to request 1 from 192.168.1.1, 1 ms
Reply to request 1 from 192.168.3.1, 2 ms
Reply to request 1 from 192.168.2.1, 2 ms
Reply to request 2 from 192.168.1.1, 1 ms
Reply to request 2 from 192.168.3.1, 3 ms
Reply to request 2 from 192.168.2.1, 3 ms
Reply to request 3 from 192.168.1.1, 1 ms
Reply to request 3 from 192.168.2.1, 2 ms
Reply to request 3 from 192.168.3.1, 2 ms
Reply to request 4 from 192.168.1.1, 1 ms
Reply to request 4 from 192.168.2.1, 2 ms
Reply to request 4 from 192.168.3.1, 2 ms
HOST1#

HOST2

HOST2#ping 225.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:

Reply to request 0 from 192.168.2.1, 1 ms
Reply to request 0 from 192.168.3.1, 2 ms
Reply to request 0 from 192.168.1.1, 2 ms
Reply to request 1 from 192.168.2.1, 1 ms
Reply to request 1 from 192.168.3.1, 3 ms
Reply to request 1 from 192.168.1.1, 3 ms
Reply to request 2 from 192.168.2.1, 1 ms
Reply to request 2 from 192.168.3.1, 2 ms
Reply to request 2 from 192.168.1.1, 2 ms
Reply to request 3 from 192.168.2.1, 1 ms
Reply to request 3 from 192.168.3.1, 2 ms
Reply to request 3 from 192.168.1.1, 2 ms
Reply to request 4 from 192.168.2.1, 1 ms
Reply to request 4 from 192.168.3.1, 2 ms
Reply to request 4 from 192.168.1.1, 2 ms
HOST2#

HOST3

HOST3#show ip igmp groups
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter   Group Accounted
225.1.1.1        GigabitEthernet0/0       01:57:03  never     192.168.3.1
HOST3#
HOST3#
HOST3#

HOST3#ping 225.1.1.1 repeat 5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 225.1.1.1, timeout is 2 seconds:

Reply to request 0 from 192.168.3.1, 1 ms
Reply to request 0 from 192.168.1.1, 2 ms
Reply to request 0 from 192.168.2.1, 2 ms
Reply to request 1 from 192.168.3.1, 1 ms
Reply to request 1 from 192.168.2.1, 3 ms
Reply to request 1 from 192.168.1.1, 2 ms
Reply to request 2 from 192.168.3.1, 1 ms
Reply to request 2 from 192.168.1.1, 2 ms
Reply to request 2 from 192.168.2.1, 2 ms
Reply to request 3 from 192.168.3.1, 1 ms
Reply to request 3 from 192.168.2.1, 2 ms
Reply to request 3 from 192.168.1.1, 2 ms
Reply to request 4 from 192.168.3.1, 1 ms
Reply to request 4 from 192.168.1.1, 2 ms
Reply to request 4 from 192.168.2.1, 2 ms
HOST3#

R1

R1#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 03:01:13, expires 00:01:59

R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/3] via 10.1.4.4, 02:25:04, GigabitEthernet1
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/3] via 10.1.5.5, 02:25:09, GigabitEthernet3
                 [110/3] via 10.1.4.4, 02:25:09, GigabitEthernet1
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/2] via 10.1.4.4, 02:25:12, GigabitEthernet1
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/2] via 10.1.5.5, 02:25:11, GigabitEthernet3
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/4] via 10.1.5.5, 02:25:09, GigabitEthernet3
                 [110/4] via 10.1.4.4, 02:25:09, GigabitEthernet1
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O        10.2.4.0/24 [110/2] via 10.1.4.4, 02:25:12, GigabitEthernet1
O        10.2.6.0/24 [110/3] via 10.1.4.4, 02:25:04, GigabitEthernet1
O        10.3.4.0/24 [110/2] via 10.1.4.4, 02:25:12, GigabitEthernet1
O        10.3.5.0/24 [110/2] via 10.1.5.5, 02:25:11, GigabitEthernet3
O        10.3.6.0/24 [110/3] via 10.1.5.5, 02:25:09, GigabitEthernet3
                     [110/3] via 10.1.4.4, 02:25:09, GigabitEthernet1
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O        172.16.0.0/29 [110/2] via 10.1.5.5, 02:25:11, GigabitEthernet3
O        172.16.0.0/30 [110/2] via 10.1.4.4, 02:25:12, GigabitEthernet1
O     192.168.2.0/24 [110/3] via 10.1.4.4, 02:25:04, GigabitEthernet1
O     192.168.3.0/24 [110/3] via 10.1.5.5, 02:25:09, GigabitEthernet3
                     [110/3] via 10.1.4.4, 02:25:09, GigabitEthernet1
R1#
R1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 02:24:28/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet1, RPF nbr: 10.1.4.4
  Incoming interface list:
    GigabitEthernet2, Accepting/Sparse
    Loopback0, Accepting/Sparse
    GigabitEthernet1, Accepting/Sparse

(*, 225.1.1.1), 02:24:28/00:02:39, RP 172.16.0.1, flags: BC
  Bidir-Upstream: GigabitEthernet1, RPF nbr 10.1.4.4
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 02:24:28/00:02:39
    GigabitEthernet1, Bidir-Upstream/Sparse, 02:24:28/stopped

(*, 224.0.1.40), 02:25:32/00:02:28, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:25:31/00:02:28

R1#
R1#

R2

R2#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 03:02:07, expires 00:02:05
R2#
R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/3] via 10.2.6.6, 02:26:15, GigabitEthernet3
                 [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/2] via 10.2.4.4, 02:26:14, GigabitEthernet1
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/4] via 10.2.6.6, 02:26:15, GigabitEthernet3
                 [110/4] via 10.2.4.4, 02:26:14, GigabitEthernet1
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/2] via 10.2.6.6, 02:26:15, GigabitEthernet3
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O        10.1.4.0/24 [110/2] via 10.2.4.4, 02:26:14, GigabitEthernet1
O        10.1.5.0/24 [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
O        10.3.4.0/24 [110/2] via 10.2.4.4, 02:26:14, GigabitEthernet1
O        10.3.5.0/24 [110/3] via 10.2.6.6, 02:26:15, GigabitEthernet3
                     [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
O        10.3.6.0/24 [110/2] via 10.2.6.6, 02:26:15, GigabitEthernet3
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O        172.16.0.0/29 [110/4] via 10.2.6.6, 02:26:15, GigabitEthernet3
                       [110/4] via 10.2.4.4, 02:26:14, GigabitEthernet1
O        172.16.0.0/30 [110/2] via 10.2.4.4, 02:26:14, GigabitEthernet1
O     192.168.1.0/24 [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
O     192.168.3.0/24 [110/3] via 10.2.6.6, 02:26:15, GigabitEthernet3
                     [110/3] via 10.2.4.4, 02:26:14, GigabitEthernet1
R2#
R2#
R2#
R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 02:25:31/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet1, RPF nbr: 10.2.4.4
  Incoming interface list:
    GigabitEthernet2, Accepting/Sparse
    GigabitEthernet3, Accepting/Sparse
    Loopback0, Accepting/Sparse
    GigabitEthernet1, Accepting/Sparse

(*, 225.1.1.1), 02:25:31/00:02:31, RP 172.16.0.1, flags: BC
  Bidir-Upstream: GigabitEthernet1, RPF nbr 10.2.4.4
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 02:25:31/00:02:31
    GigabitEthernet1, Bidir-Upstream/Sparse, 02:25:31/stopped

(*, 224.0.1.40), 02:26:32/00:02:32, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:26:31/00:02:32

R2#

R3

R3#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 03:02:56, expires 00:02:19
R3#

R3#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/3] via 10.3.5.5, 02:27:07, GigabitEthernet3
                 [110/3] via 10.3.4.4, 02:27:07, GigabitEthernet1
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/3] via 10.3.6.6, 02:27:04, GigabitEthernet4
                 [110/3] via 10.3.4.4, 02:27:01, GigabitEthernet1
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/2] via 10.3.4.4, 02:27:07, GigabitEthernet1
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/2] via 10.3.5.5, 02:27:07, GigabitEthernet3
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/2] via 10.3.6.6, 02:27:06, GigabitEthernet4
      10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O        10.1.4.0/24 [110/2] via 10.3.4.4, 02:27:07, GigabitEthernet1
O        10.1.5.0/24 [110/2] via 10.3.5.5, 02:27:07, GigabitEthernet3
O        10.2.4.0/24 [110/2] via 10.3.4.4, 02:27:07, GigabitEthernet1
O        10.2.6.0/24 [110/2] via 10.3.6.6, 02:27:06, GigabitEthernet4
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O        172.16.0.0/29 [110/2] via 10.3.5.5, 02:27:07, GigabitEthernet3
O        172.16.0.0/30 [110/2] via 10.3.4.4, 02:27:07, GigabitEthernet1
O     192.168.1.0/24 [110/3] via 10.3.5.5, 02:27:07, GigabitEthernet3
                     [110/3] via 10.3.4.4, 02:27:07, GigabitEthernet1
O     192.168.2.0/24 [110/3] via 10.3.6.6, 02:27:04, GigabitEthernet4
                     [110/3] via 10.3.4.4, 02:27:01, GigabitEthernet1
R3#
R3#
R3#
R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 02:26:22/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet1, RPF nbr: 10.3.4.4
  Incoming interface list:
    GigabitEthernet4, Accepting/Sparse
    GigabitEthernet2, Accepting/Sparse
    Loopback0, Accepting/Sparse
    GigabitEthernet1, Accepting/Sparse

(*, 225.1.1.1), 02:26:21/00:02:43, RP 172.16.0.1, flags: BC
  Bidir-Upstream: GigabitEthernet1, RPF nbr 10.3.4.4
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 02:26:21/00:02:43
    GigabitEthernet1, Bidir-Upstream/Sparse, 02:26:21/stopped

(*, 224.0.1.40), 02:27:24/00:02:40, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:27:23/00:02:40

R3#

R4

R4#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1
R4#
R4#
R4#
R4#show ip route connected
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      4.0.0.0/32 is subnetted, 1 subnets
C        4.4.4.4 is directly connected, Loopback0
      10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
C        10.1.4.0/24 is directly connected, GigabitEthernet1
L        10.1.4.4/32 is directly connected, GigabitEthernet1
C        10.2.4.0/24 is directly connected, GigabitEthernet2
L        10.2.4.4/32 is directly connected, GigabitEthernet2
C        10.3.4.0/24 is directly connected, GigabitEthernet3
L        10.3.4.4/32 is directly connected, GigabitEthernet3
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
C        172.16.0.0/30 is directly connected, Loopback1
L        172.16.0.1/32 is directly connected, Loopback1
R4#
R4#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/2] via 10.1.4.1, 02:48:03, GigabitEthernet1
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 10.2.4.2, 02:47:59, GigabitEthernet2
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/2] via 10.3.4.3, 02:48:01, GigabitEthernet3
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/3] via 10.3.4.3, 02:47:59, GigabitEthernet3
                 [110/3] via 10.1.4.1, 02:48:01, GigabitEthernet1
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/3] via 10.3.4.3, 02:48:01, GigabitEthernet3
                 [110/3] via 10.2.4.2, 02:47:59, GigabitEthernet2
      10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O        10.1.5.0/24 [110/2] via 10.1.4.1, 02:48:03, GigabitEthernet1
O        10.2.6.0/24 [110/2] via 10.2.4.2, 02:47:59, GigabitEthernet2
O        10.3.5.0/24 [110/2] via 10.3.4.3, 02:48:01, GigabitEthernet3
O        10.3.6.0/24 [110/2] via 10.3.4.3, 02:48:01, GigabitEthernet3
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
O        172.16.0.0/29 [110/3] via 10.3.4.3, 02:47:59, GigabitEthernet3
                       [110/3] via 10.1.4.1, 02:48:01, GigabitEthernet1
O     192.168.1.0/24 [110/2] via 10.1.4.1, 02:48:03, GigabitEthernet1
O     192.168.2.0/24 [110/2] via 10.2.4.2, 02:47:59, GigabitEthernet2
O     192.168.3.0/24 [110/2] via 10.3.4.3, 02:48:01, GigabitEthernet3
R4#
R4#
R4#
R4#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 02:48:19/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: Loopback1, RPF nbr: 172.16.0.1
  Incoming interface list:
    GigabitEthernet3, Accepting/Sparse
    GigabitEthernet2, Accepting/Sparse
    GigabitEthernet1, Accepting/Sparse
    Loopback0, Accepting/Sparse
    Loopback1, Accepting/Sparse

(*, 225.1.1.1), 02:47:18/00:03:23, RP 172.16.0.1, flags: B
  Bidir-Upstream: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 02:47:18/00:03:23
    GigabitEthernet3, Forward/Sparse, 02:47:18/00:02:33
    GigabitEthernet1, Forward/Sparse, 02:47:18/00:02:37

(*, 224.0.1.40), 02:48:19/00:02:42, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:48:18/00:02:42

R4#

R5

R5#show ip pim rp
R5#
R5#
R5#
R5#show ip pim rp map
R5#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is a candidate RP (v2)
This system is the Bootstrap Router (v2)

Group(s) 224.0.0.0/4
  RP 172.16.0.1 (?), v2, bidir
    Info source: 172.16.0.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 03:08:21, expires: 00:02:06
R5#
R5#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/2] via 10.1.5.1, 02:48:44, GigabitEthernet1
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/4] via 10.3.5.3, 02:48:40, GigabitEthernet2
                 [110/4] via 10.1.5.1, 02:48:36, GigabitEthernet1
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/2] via 10.3.5.3, 02:48:42, GigabitEthernet2
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/3] via 10.3.5.3, 02:48:42, GigabitEthernet2
                 [110/3] via 10.1.5.1, 02:48:44, GigabitEthernet1
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/3] via 10.3.5.3, 02:48:41, GigabitEthernet2
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O        10.1.4.0/24 [110/2] via 10.1.5.1, 02:48:44, GigabitEthernet1
O        10.2.4.0/24 [110/3] via 10.3.5.3, 02:48:42, GigabitEthernet2
                     [110/3] via 10.1.5.1, 02:48:44, GigabitEthernet1
O        10.2.6.0/24 [110/3] via 10.3.5.3, 02:48:41, GigabitEthernet2
O        10.3.4.0/24 [110/2] via 10.3.5.3, 02:48:42, GigabitEthernet2
O        10.3.6.0/24 [110/2] via 10.3.5.3, 02:48:42, GigabitEthernet2
      172.16.0.0/16 is variably subnetted, 3 subnets, 3 masks
O        172.16.0.0/30 [110/3] via 10.3.5.3, 02:48:42, GigabitEthernet2
                       [110/3] via 10.1.5.1, 02:48:44, GigabitEthernet1
O     192.168.1.0/24 [110/2] via 10.1.5.1, 02:48:44, GigabitEthernet1
O     192.168.2.0/24 [110/4] via 10.3.5.3, 02:48:40, GigabitEthernet2
                     [110/4] via 10.1.5.1, 02:48:36, GigabitEthernet1
O     192.168.3.0/24 [110/2] via 10.3.5.3, 02:48:42, GigabitEthernet2
R5#
R5#
R5#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 02:48:58/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: Loopback1, RPF nbr: 172.16.0.1
  Incoming interface list:
    GigabitEthernet2, Accepting/Sparse
    GigabitEthernet1, Accepting/Sparse
    Loopback0, Accepting/Sparse
    Loopback1, Accepting/Sparse

(*, 224.0.1.40), 02:48:58/00:02:02, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:48:57/00:02:02

R5#

R6

R6#show ip pim rp
R6#
R6#
R6#
R6#show ip pim rp map
R6#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 172.16.0.1 (?), v2, bidir
    Info source: 172.16.0.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 03:08:18, expires: 00:01:58
R6#
R6#
R6#
R6#
R6#sh ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/4] via 10.3.6.3, 02:49:22, GigabitEthernet2
                 [110/4] via 10.2.6.2, 02:49:21, GigabitEthernet1
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 10.2.6.2, 02:49:21, GigabitEthernet1
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/2] via 10.3.6.3, 02:49:22, GigabitEthernet2
      4.0.0.0/32 is subnetted, 1 subnets
O        4.4.4.4 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
                 [110/3] via 10.2.6.2, 02:49:21, GigabitEthernet1
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O        10.1.4.0/24 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
                     [110/3] via 10.2.6.2, 02:49:21, GigabitEthernet1
O        10.1.5.0/24 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
O        10.2.4.0/24 [110/2] via 10.2.6.2, 02:49:21, GigabitEthernet1
O        10.3.4.0/24 [110/2] via 10.3.6.3, 02:49:22, GigabitEthernet2
O        10.3.5.0/24 [110/2] via 10.3.6.3, 02:49:22, GigabitEthernet2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O        172.16.0.0/29 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
O        172.16.0.0/30 [110/3] via 10.3.6.3, 02:49:22, GigabitEthernet2
                       [110/3] via 10.2.6.2, 02:49:21, GigabitEthernet1
O     192.168.1.0/24 [110/4] via 10.3.6.3, 02:49:22, GigabitEthernet2
                     [110/4] via 10.2.6.2, 02:49:21, GigabitEthernet1
O     192.168.2.0/24 [110/2] via 10.2.6.2, 02:49:21, GigabitEthernet1
O     192.168.3.0/24 [110/2] via 10.3.6.3, 02:49:22, GigabitEthernet2
R6#
R6#
R6#
R6#
R6#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 02:48:38/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet2, RPF nbr: 10.3.6.3
  Incoming interface list:
    Loopback0, Accepting/Sparse
    GigabitEthernet2, Accepting/Sparse

(*, 224.0.1.40), 02:49:40/00:02:22, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:49:39/00:02:22

R6#

RP Failure

R1

R1#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 02:52:37, expires 00:01:59
R1#
R1#
R1#
R1#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/5] via 10.1.5.5, 00:02:13, GigabitEthernet3
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/3] via 10.1.5.5, 02:53:30, GigabitEthernet3
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/2] via 10.1.5.5, 02:53:32, GigabitEthernet3
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/4] via 10.1.5.5, 02:53:30, GigabitEthernet3
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O        10.2.4.0/24 [110/5] via 10.1.5.5, 00:02:12, GigabitEthernet3
O        10.2.6.0/24 [110/4] via 10.1.5.5, 00:02:13, GigabitEthernet3
O        10.3.4.0/24 [110/3] via 10.1.5.5, 00:02:13, GigabitEthernet3
O        10.3.5.0/24 [110/2] via 10.1.5.5, 02:53:32, GigabitEthernet3
O        10.3.6.0/24 [110/3] via 10.1.5.5, 02:53:30, GigabitEthernet3
      172.16.0.0/29 is subnetted, 1 subnets
O        172.16.0.0 [110/2] via 10.1.5.5, 02:53:32, GigabitEthernet3
O     192.168.2.0/24 [110/5] via 10.1.5.5, 00:02:13, GigabitEthernet3
O     192.168.3.0/24 [110/3] via 10.1.5.5, 02:53:30, GigabitEthernet3
R1#
R1#
R1#
R1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 00:02:16/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet3, RPF nbr: 10.1.5.5
  Incoming interface list:
    GigabitEthernet3, Accepting/Sparse
    GigabitEthernet1, Accepting/Sparse
    GigabitEthernet2, Accepting/Sparse
    Loopback0, Accepting/Sparse

(*, 225.1.1.1), 02:52:49/00:02:11, RP 172.16.0.1, flags: BC
  Bidir-Upstream: GigabitEthernet3, RPF nbr 10.1.5.5
  Outgoing interface list:
    GigabitEthernet3, Bidir-Upstream/Sparse, 00:02:19/stopped
    GigabitEthernet2, Forward/Sparse, 02:52:49/00:02:11

(*, 224.0.1.40), 02:53:53/00:02:13, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:53:52/00:02:13

R1#

R2

R2#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 02:53:26, expires 00:02:12
R2#
R2#
R2#
R2#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/5] via 10.2.6.6, 00:03:02, GigabitEthernet3
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/3] via 10.2.6.6, 02:54:19, GigabitEthernet3
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/4] via 10.2.6.6, 02:54:19, GigabitEthernet3
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/2] via 10.2.6.6, 02:54:19, GigabitEthernet3
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O        10.1.4.0/24 [110/5] via 10.2.6.6, 00:02:58, GigabitEthernet3
O        10.1.5.0/24 [110/4] via 10.2.6.6, 00:03:02, GigabitEthernet3
O        10.3.4.0/24 [110/3] via 10.2.6.6, 00:02:58, GigabitEthernet3
O        10.3.5.0/24 [110/3] via 10.2.6.6, 02:54:19, GigabitEthernet3
O        10.3.6.0/24 [110/2] via 10.2.6.6, 02:54:19, GigabitEthernet3
      172.16.0.0/29 is subnetted, 1 subnets
O        172.16.0.0 [110/4] via 10.2.6.6, 02:54:19, GigabitEthernet3
O     192.168.1.0/24 [110/5] via 10.2.6.6, 00:03:02, GigabitEthernet3
O     192.168.3.0/24 [110/3] via 10.2.6.6, 02:54:19, GigabitEthernet3
R2#
R2#
R2#
R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 00:03:03/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet3, RPF nbr: 10.2.6.6
  Incoming interface list:
    GigabitEthernet1, Accepting/Sparse
    GigabitEthernet3, Accepting/Sparse
    GigabitEthernet2, Accepting/Sparse
    Loopback0, Accepting/Sparse

(*, 225.1.1.1), 02:53:36/00:02:34, RP 172.16.0.1, flags: BC
  Bidir-Upstream: GigabitEthernet3, RPF nbr 10.2.6.6
  Outgoing interface list:
    GigabitEthernet3, Bidir-Upstream/Sparse, 00:03:03/stopped
    GigabitEthernet2, Forward/Sparse, 02:53:36/00:02:34

(*, 224.0.1.40), 02:54:37/00:02:26, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:54:36/00:02:26

R2#

R3

R3#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 02:54:14, expires 00:02:24
R3#
R3#
R3#
R3#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/3] via 10.3.5.5, 02:55:07, GigabitEthernet3
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/3] via 10.3.6.6, 02:55:04, GigabitEthernet4
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/2] via 10.3.5.5, 02:55:07, GigabitEthernet3
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/2] via 10.3.6.6, 02:55:06, GigabitEthernet4
      10.0.0.0/8 is variably subnetted, 10 subnets, 2 masks
O        10.1.4.0/24 [110/3] via 10.3.5.5, 00:03:47, GigabitEthernet3
O        10.1.5.0/24 [110/2] via 10.3.5.5, 02:55:07, GigabitEthernet3
O        10.2.4.0/24 [110/3] via 10.3.6.6, 00:03:47, GigabitEthernet4
O        10.2.6.0/24 [110/2] via 10.3.6.6, 02:55:06, GigabitEthernet4
      172.16.0.0/29 is subnetted, 1 subnets
O        172.16.0.0 [110/2] via 10.3.5.5, 02:55:07, GigabitEthernet3
O     192.168.1.0/24 [110/3] via 10.3.5.5, 02:55:07, GigabitEthernet3
O     192.168.2.0/24 [110/3] via 10.3.6.6, 02:55:04, GigabitEthernet4
R3#
R3#
R3#
R3#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 00:03:50/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet3, RPF nbr: 10.3.5.5
  Incoming interface list:
    GigabitEthernet4, Accepting/Sparse
    GigabitEthernet3, Accepting/Sparse
    GigabitEthernet1, Accepting/Sparse
    GigabitEthernet2, Accepting/Sparse
    Loopback0, Accepting/Sparse

(*, 225.1.1.1), 02:54:23/00:02:46, RP 172.16.0.1, flags: BC
  Bidir-Upstream: GigabitEthernet3, RPF nbr 10.3.5.5
  Outgoing interface list:
    GigabitEthernet4, Forward/Sparse, 00:03:50/00:02:33
    GigabitEthernet3, Bidir-Upstream/Sparse, 00:03:50/stopped
    GigabitEthernet2, Forward/Sparse, 02:54:23/00:02:46

(*, 224.0.1.40), 02:55:26/00:02:42, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:55:25/00:02:42

R3#

R5

R5#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1
R5#
R5#
R5#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/2] via 10.1.5.1, 02:56:06, GigabitEthernet1
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/4] via 10.3.5.3, 02:56:02, GigabitEthernet2
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/2] via 10.3.5.3, 02:56:04, GigabitEthernet2
      6.0.0.0/32 is subnetted, 1 subnets
O        6.6.6.6 [110/3] via 10.3.5.3, 02:56:03, GigabitEthernet2
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O        10.1.4.0/24 [110/2] via 10.1.5.1, 02:56:06, GigabitEthernet1
O        10.2.4.0/24 [110/4] via 10.3.5.3, 00:04:45, GigabitEthernet2
O        10.2.6.0/24 [110/3] via 10.3.5.3, 02:56:03, GigabitEthernet2
O        10.3.4.0/24 [110/2] via 10.3.5.3, 02:56:04, GigabitEthernet2
O        10.3.6.0/24 [110/2] via 10.3.5.3, 02:56:04, GigabitEthernet2
O     192.168.1.0/24 [110/2] via 10.1.5.1, 02:56:06, GigabitEthernet1
O     192.168.2.0/24 [110/4] via 10.3.5.3, 02:56:02, GigabitEthernet2
O     192.168.3.0/24 [110/2] via 10.3.5.3, 02:56:04, GigabitEthernet2
R5#
R5#show ip route connected
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      5.0.0.0/32 is subnetted, 1 subnets
C        5.5.5.5 is directly connected, Loopback0
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
C        10.1.5.0/24 is directly connected, GigabitEthernet1
L        10.1.5.5/32 is directly connected, GigabitEthernet1
C        10.3.5.0/24 is directly connected, GigabitEthernet2
L        10.3.5.5/32 is directly connected, GigabitEthernet2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/29 is directly connected, Loopback1
L        172.16.0.1/32 is directly connected, Loopback1
R5#
R5#
R5#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 02:56:33/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: Loopback1, RPF nbr: 172.16.0.1
  Incoming interface list:
    GigabitEthernet2, Accepting/Sparse
    GigabitEthernet1, Accepting/Sparse
    Loopback0, Accepting/Sparse
    Loopback1, Accepting/Sparse

(*, 225.1.1.1), 00:05:02/00:03:15, RP 172.16.0.1, flags: B
  Bidir-Upstream: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet2, Forward/Sparse, 00:04:59/00:03:13
    GigabitEthernet1, Forward/Sparse, 00:05:02/00:03:15

(*, 224.0.1.40), 02:56:33/00:02:27, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:56:32/00:02:27

R5#

R6

R6#show ip pim rp
Group: 225.1.1.1, RP: 172.16.0.1, uptime 02:56:06, expires 00:01:32
R6#
R6#
R6#show ip route ospf
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, m - OMP
       n - NAT, Ni - NAT inside, No - NAT outside, Nd - NAT DIA
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       H - NHRP, G - NHRP registered, g - NHRP registration summary
       o - ODR, P - periodic downloaded static route, l - LISP
       a - application route
       + - replicated route, % - next hop override, p - overrides from PfR
       & - replicated local route overrides by connected

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/4] via 10.3.6.3, 02:56:59, GigabitEthernet2
      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 10.2.6.2, 02:56:58, GigabitEthernet1
      3.0.0.0/32 is subnetted, 1 subnets
O        3.3.3.3 [110/2] via 10.3.6.3, 02:56:59, GigabitEthernet2
      5.0.0.0/32 is subnetted, 1 subnets
O        5.5.5.5 [110/3] via 10.3.6.3, 02:56:59, GigabitEthernet2
      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O        10.1.4.0/24 [110/4] via 10.3.6.3, 00:05:38, GigabitEthernet2
O        10.1.5.0/24 [110/3] via 10.3.6.3, 02:56:59, GigabitEthernet2
O        10.2.4.0/24 [110/2] via 10.2.6.2, 02:56:58, GigabitEthernet1
O        10.3.4.0/24 [110/2] via 10.3.6.3, 02:56:59, GigabitEthernet2
O        10.3.5.0/24 [110/2] via 10.3.6.3, 02:56:59, GigabitEthernet2
      172.16.0.0/29 is subnetted, 1 subnets
O        172.16.0.0 [110/3] via 10.3.6.3, 02:56:59, GigabitEthernet2
O     192.168.1.0/24 [110/4] via 10.3.6.3, 02:56:59, GigabitEthernet2
O     192.168.2.0/24 [110/2] via 10.2.6.2, 02:56:58, GigabitEthernet1
O     192.168.3.0/24 [110/2] via 10.3.6.3, 02:56:59, GigabitEthernet2
R6#
R6#
R6#
R6#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group, c - PFP-SA cache created entry,
       * - determined by Assert, # - iif-starg configured on rpf intf,
       e - encap-helper tunnel flag
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*,224.0.0.0/4), 00:05:42/-, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet2, RPF nbr: 10.3.6.3
  Incoming interface list:
    GigabitEthernet1, Accepting/Sparse
    GigabitEthernet2, Accepting/Sparse
    Loopback0, Accepting/Sparse

(*, 225.1.1.1), 00:05:43/00:03:19, RP 172.16.0.1, flags: B
  Bidir-Upstream: GigabitEthernet2, RPF nbr 10.3.6.3
  Outgoing interface list:
    GigabitEthernet1, Forward/Sparse, 00:05:41/00:03:19
    GigabitEthernet2, Bidir-Upstream/Sparse, 00:05:42/stopped

(*, 224.0.1.40), 02:57:17/00:02:45, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:57:16/00:02:45

R6#